AGP 2.9 - Data Type Long now displaying as Double

406
2
Jump to solution
01-19-2022 08:47 AM
WilliamPollock
New Contributor III

We have an ArcGIS Pro .NET Addin that creates and displays a Stand Alone Table from a query of an Oracle database view.

From AGP 2.3 through 2.8, the Addin rendered all fields of data appropriately.

From AGP 2.3 through 2.8, one specific field of Oracle data type NUMBER(38) rendered/displayed in the Table object as ArcGIS data type Long.

But starting with AGP 2.9, this one specific field of Oracle data type NUMBER(38) now renders as ArcGIS data type Double, and values all show as "0" (zero).

Our Oracle database view has not changed, and our AGP .NET Addin code has not changed; the only change was the upgrade to AGP 2.9.

Any ideas as to why the same table/field/data type renders as Long in AGP 2.8 but as Double in AGP 2.9?

0 Kudos
1 Solution

Accepted Solutions
RichRuh
Esri Regular Contributor

Hi William,

NUMBER(38) is large enough to represent a 64-bit integer. We changed our code to present this as a Double as a stop-gap until we can fully represent 64-bit integer types in ArcGIS.

The values should not show as 0; you should log that as an issue with technical support so that we can reproduce and fix it.

Thanks,

--Rich

View solution in original post

0 Kudos
2 Replies
RichRuh
Esri Regular Contributor

Hi William,

NUMBER(38) is large enough to represent a 64-bit integer. We changed our code to present this as a Double as a stop-gap until we can fully represent 64-bit integer types in ArcGIS.

The values should not show as 0; you should log that as an issue with technical support so that we can reproduce and fix it.

Thanks,

--Rich

0 Kudos
WilliamPollock
New Contributor III

Hi Rich - 

Thank you for the information about how Oracle data type NUMBER(38) was previously represented (as LONG) and is now represented (as DOUBLE) by ArcGIS. 

Because there are non-GIS business reasons to maintain the field in question, our temporary approach to handle the data type change was to create another field/column of Oracle data type NUMBER(10), which ArcGIS handles as LONG, and use that new field in the Addin. 

The values of zero were due to attempts at casting the now DOUBLE field values as LONG in the .NET Addin code; we have resolved this aspect of the issue and the expected values are being displayed in the table  of the Addin. 

Thank you again, and best regards. 

+ bill