Web Map Share - Pro

1903
6
Jump to solution
03-18-2019 12:51 PM
chadhickman
Occasional Contributor II

So I have created a map in Pro and I have about 20-25 layers. I am wanting to Share this map as a Web Map with my organization on ArcGIS Online. When I go to the 'Share' tab and select 'Web Map' everything works smoothly. I analyze my map and the only warnings I get are that my layers do not have feature template. After that I select who I am going to share my map with I hit 'Share' button. After this the progress bar simply states "Queueing.' It has been stuck like this for over an hour, is this normal? Do I have too many layers? Doing something else wrong?

Appreciate any feedback!

0 Kudos
1 Solution

Accepted Solutions
rachelg_esri
Esri Contributor

Hello Chad,

I have a quick idea... Could you perhaps have ran into a publishing interruption at some point, which got stuck and prevents any future publishing? This sounds similar to a case I handled recently.

With Esri software closed, please go ahead and try renaming the following directory on your machine:

C:\Users\<USERPROFILE>\AppData\Local\ESRI\ArcGISPro

Renaming the folder allows you to revert your changes if needed. Go ahead and rename that to ArcGISPro_Old, then re-launch ArcGIS Pro and try publishing again.

That should clear out your job queue. I'd like to see if that fixes the issue.

Thanks!

-- Rachel

Esri Support Services

Rachel Guttmacher
ArcGIS Online Technology Lead
Esri Support Services

View solution in original post

6 Replies
rachelg_esri
Esri Contributor

Hello Chad,

If the program is publishing that many layers, depending on your network it may take a while, but this does sound a little excessive. Do you see the same issue if you try publishing on another network? For example, if it's a laptop, take it to a library or take it home from work - can you publish faster there? We often see security software get in the way of publishing. Can you just publish one layer successfully? (Right-click the layer in the Table of Contents > Share as > Web Layer).

Thanks!

Rachel

Esri Support Services

Rachel Guttmacher
ArcGIS Online Technology Lead
Esri Support Services
0 Kudos
chadhickman
Occasional Contributor II

Rachel,

Something isn't right. I have tried share a much smaller Web Map, 1-2 layers, and I am still stuck on queueing. I also tried to share just a single Web Layer and I am having the same issue. Just last week when I was experimenting with this same process the Web Map was sharing nearly instantaneously. Do you have any solutions in mind?

FYI, I am on my works network which is pretty robust so..

Chad 

0 Kudos
rachelg_esri
Esri Contributor

Hello Chad,

I'd definitely try narrowing down the issue. All of the below have been frequent scenarios we see in Support:

- Try the same computer on another network -- this helps troubleshoot network issues

- Try a different computer on the same network -- this helps us determine if it's your computer/install

- If you are logging in to Windows on that machine, have another colleague try logging into Windows and doing the same workflow -- this helps troubleshoot potentially corrupted Windows profiles

- You already tried another dataset, so we know that's not the problem

- Do you have ArcMap on your machine? Does that publish successfully?

- If you save one of the layers as a shapefile, then zip all the component pieces into a zip folder, and add it to ArcGIS Online using My Content, does that succeed? -- This helps us determine if there's something wrong with your username or organization

If the above computer/network suggestions aren't an option, we can always get into further troubleshooting of your install/machine, but I tend to suggest starting with the narrow-down steps to be sure you're going in the right direction. Other troubleshooting would include renaming a few folders in a few key locations and, potentially, running a repair or uninstall/reinstall of the software as needed.

Best regards,

Rachel

Esri Support Services

Rachel Guttmacher
ArcGIS Online Technology Lead
Esri Support Services
0 Kudos
chadhickman
Occasional Contributor II

Rachel,

I am thinking this is a Pro issue, although, I was able to do share to a Web Map just last Friday (3/15). I was able to share a map package from ArcMap (not sure how you share Web Map from ArcMap?)?

I have tried several different files types and folders when sharing from Pro and it just "hangs" in the queuing stage.

Chad

0 Kudos
rachelg_esri
Esri Contributor

Hello Chad,

I have a quick idea... Could you perhaps have ran into a publishing interruption at some point, which got stuck and prevents any future publishing? This sounds similar to a case I handled recently.

With Esri software closed, please go ahead and try renaming the following directory on your machine:

C:\Users\<USERPROFILE>\AppData\Local\ESRI\ArcGISPro

Renaming the folder allows you to revert your changes if needed. Go ahead and rename that to ArcGISPro_Old, then re-launch ArcGIS Pro and try publishing again.

That should clear out your job queue. I'd like to see if that fixes the issue.

Thanks!

-- Rachel

Esri Support Services

Rachel Guttmacher
ArcGIS Online Technology Lead
Esri Support Services
VincentRobinson
New Contributor III

I've tried this ,it cleared out the que but when I tried to publish a new feature it still got hung up. can some help me please? 

0 Kudos