Stop the file bloat!!!

176
5
06-21-2021 03:52 PM
Labels (2)
EllenSaxon
New Contributor III

How do I stop the file bloat that ArcGIS Pro automatically creates?!!! It is driving me nuts. 

I have the options set so it doesn't create a new folder with each new project, but I also do not need a toolbox for every project. Some projects will create a blank folder when I open the project. I delete the folder, but next time I open the project it creates it again! It doesn't even have any files! I can delete the unwanted toolboxes and thankfully they do not respawn. I am not even going to complain about the .backups folder because I am sure it serves a purpose.

I am hoping I have missed a simple check box setting to prevent this unnecessary and annoying file bloat, please point me in the right direction.

 

 

0 Kudos
5 Replies
DanPatterson
MVP Honored Contributor

a few.... toggle off what you don't want

projoptions.png


... sort of retired...
0 Kudos
EllenSaxon
New Contributor III

These are my current settings 🙃

EllenSaxon_0-1624324445586.png

 

0 Kudos
DanPatterson
MVP Honored Contributor

specify a specific output folder, like in my example.  I put all my projects in one location, but a subfolder therein.  I don't like "default locations" since I am not sure what they are if they aren't specified.

Some folders are needed, even temporarily.  Delete at your own peril ;).  Disk space is cheap, clean out your gdb data and dump your display cache regularly.

If it is more performance issues you are suspecting, see Kory's post

Troubleshooting Performance Issues in ArcGIS Pro - Esri Community

Good luck!


... sort of retired...
0 Kudos
EllenSaxon
New Contributor III

I specify the project location each time. Disk space is cheap, but the additional folders and files make navigating the server more annoying. I have trust issues with gdbs, so I don't usually use them. 

Performance is a whole other issue! erhg

thanks 

0 Kudos
DanPatterson
MVP Honored Contributor

use a gdb ... I finally came around

server ... never have that problem, local machine for me, ship when done


... sort of retired...
0 Kudos