Replication ERROR 000800 The value is not a member of

217
3
12-27-2021 02:11 PM
El_Saket
New Contributor III

I am trying to do Checkout/in replica, all things goes very well. Unless deciding  to create a new replica on the same gdb (Multiuser or File Gdb), I can create a replica with no errors and edits also, issue only appears when using synchronize tool 2nd time on same gdb it gives my the old Replica name with an error ERROR 000800 The value is not a member of DataBaseName.

to solve this issue I have to exit and reopen ArcGIS pro which is not logic, after the first Checkout/In replica I deleted all data (FC's) in the child DB also I make sure that no replicas are exist for the Parent & Child.  Therefore I build a new Checkout replica.  

0 Kudos
3 Replies
Robert_LeClair
Esri Frequent Contributor

With checkout/checkin replication the replica pairs exist for only 1 round trip interaction, meaning you create the child replica, do edits in the child gdb, and synchronize back to the parent gdb.  That synchronization deletes the replica pair in both parent and child gdb.  If you attempt a 2nd synchronization it will fail as the replica pairs don't exist any more.  If you want to do more edits in the child gdb, you have to create a new checkout/checkin replica.  Basically, the replica pairs do not persist like they do with one way or two way replication.

0 Kudos
El_Saket
New Contributor III

thanks Robert, I know that Checkout/in exist for only 1 round once you Sync, replica is deleted. But my issue is that, I cannot sync two times for two different replicas (checkout/in) in one ArcPro session, because the replica parameter in the synchronize tool point on old checkout/in replica (which already deleted) and the new replica doesn't exist, it appears only after exit and re-open ArcPro.!!

0 Kudos
Robert_LeClair
Esri Frequent Contributor

I was able to reproduce on my side and see what you're talking about.  My recommendation is to contact Esri Support Services, work with an analyst to reproduce the error messaging and have them log this as a bug.  As a caveat, I do not work in Esri Support Services but do teach the GDB Replication Instructor Led class.

0 Kudos