"Tool has failed to open: stats..." issue for all Spatial Statistics tools

884
2
09-23-2018 06:03 PM
hashimotoy2
New Contributor III

Quite suddenly last night, the message "Tool has failed to open: stats.ExploratoryRegression"... occurs when I try to open any of the tools in the Spatial Statistics tools in the toolbox e.g. stats.IncrementalSpatialAutocorrelation. I had run these tools earlier in the evening.

I checked the web for similar issues and came across this post:

Problem: After upgrading to ArcGIS Pro 2.2, geoprocessing tools fail to load and Python window retur... 

however, the cause identified in the above solution states this occurs upon update of version 2.1 to 2.2 causing the Pro Python Package manager to install a later version of Python than what is shipped with Pro (python 3.6.2 to 3.6.6) and that it results in missing 4 files: python.exe, python3.dll, python36.dll, pythonw.exe. However, all of these files are intact and I have been on v2.2 for a while.

My current setup: Windows 10, ArcGIS Pro v2.2.2.12813, Advanced User

I have access to a remote connection to a workstation running the same version of Pro and am experiencing the same problem. On the remote desktop I did try the Conda solution described in the above despite not having the same problem, but have only limited admin privileges and am not able to change the read-only setting on the Python\bin folder despite adding the Attributes column to the details view in window and applying the command

      attrib -r +s "c:\program files\arcgis\pro\bin"

however this did not change the read-only property despite running the command and seeming to apply the changes to all of the subfolders and files.

***UPDATE - my workaround was to install an older version of Pro v. 2.0 for which I had the executable, and update the software via the update function. It appears to be working fine for now.

Tags (2)
2 Replies
AlicanKaraer
New Contributor

Hi there, I am quite new here but I got the same problem when I recently updated my ArcGIS Pro from 2.5 to 2.7. All Spatial statistics tools have stopped working with the same error "Tool has failed to open" although there was no problem before the update.  I have an Advanced User license from my university and don't know how to turn back to v2.5. Any help/suggestion would be appreciated

 

**EDIT** I don't know how but all problems have solved after creating a new clone of the default python environment. 

zhiyuanyaogis
New Contributor II

Thank you Alican for the information! I had the same problem after upgrading from version 2.3 to 2.7. I checked the python environment and cloned it. Now the spatial statistics toolbox works. Thank you so much for the useful information! It saves me tons of time. 

0 Kudos