Select to view content in your preferred language

Problem Exporting SVG Logo on Layout to PDF

570
3
07-06-2023 11:39 AM
Labels (1)
KeithWitt
New Contributor III

I have an issue with the resolution of SVG logos when they are exported as PDF from a map layout in ArcGIS Pro. The SVG graphic was created in Adobe Illustrator and exports to PDF properly from that software. See the jagged corners of "R" and "C" on the right side of the attached image. The left side is Illustrator to PDF, and the right side is ArcGIS Pro to PDF. I tested all the compression and resolution settings but nothing helped. Exporting to high-res PNG smooths out the characters so it seems to be a vector issue. Thoughts?

0 Kudos
3 Replies
AubriKinghorn
Esri Regular Contributor

Do you have embed fonts checked in your export? Convert markers to symbols may also be good to check for this kind of export.

Cheers,
Aubri
0 Kudos
KeithWitt
New Contributor III

I tested all the parameters in various combinations and none of them help. The SVG file is a very simple at only 13kb. The SVG looks fine in Pro. It exports fine as raster (png, jpg) and even PDF > Output as image.

0 Kudos
KeithWitt
New Contributor III

I developed two workarounds:

1) Convert the SVG file to EMF format in Illustrator or other software and then insert it into Pro before exporting to PDF for crisp, vector output. It seems Pro handles the bezier curves of the EMF format differently than the SVG format.

2) ArcGIS Pro > .AIX > ArcGIS Maps for Adobe Creative Cloud in Illustrator. Then, add the SVG logo in Illustrator before creating the PDF. You could also do Pro > PDF > Illustrator but with less organized layering.

0 Kudos