Select to view content in your preferred language

Performance Issues with Windows 11

1509
7
07-17-2023 09:05 AM
Labels (1)
Thomas_Z2
New Contributor III

I am using ArcGIS Pro 3.1.2 on Windows 11.

When I edit features (Edit Vertices), my computer slows down over time until I can't work anymore.

Checking the task manager, I can see that my internal GPU is 100% even though I have Windows 11 configured to use my dedicated GPU (NVIDIA RTX A2000 Laptop GPU) for ArcGISPro.exe.

Investigating further, it seems that WDM.exe (Windows Desktop Manager) is fully utilize the internal GPU while using ArcGIS Pro. However, that doesn't happen right away.. maybe a few minutes to half hour into editing.

The issue also occurs in other situations than editing. Sometimes it is even happening while having ArcGIS Pro open in the background. I only have performance issues while working with ArcGIS Pro. 

Anyone having the same experience and may have an idea how to solve this issue?

7 Replies
Thomas_Z2
New Contributor III

Addendum: I haven't experienced issues while using ArcGIS Pro 3.1.x with Windows 10. I had the same issues with Windows 11 and ArcGIS Pro 3.1.1.

0 Kudos
Robert_LeClair
Esri Notable Contributor

There is a great ArcGIS Pro document that provides many tips/tricks to troubleshoot performance issues in ArcGIS Pro you can see here.  It's a good place to start but also may be worthy of a Support Call to Esri.

0 Kudos
Thomas_Z2
New Contributor III

Thank you, I integrated restarting ArcGIS Pro in my temporary workflow... I am really happy with ArcGIS Pro but it's annoying that it consumes so much resources. I rarely or never use 3D... Still have to investigate why everything is so slow after a while. 

0 Kudos
MarcelSt-Germain
Regular Contributor

Pro is always slow.  Almost 2 min for each move in editing.  So, moving from arcmap to Pro was not for a speed bump but make work slower.  

Change computer for a new one with more ram, SSD drive change nothing.  So real work is less than one hour by day of work.

0 Kudos
Robert_LeClair
Esri Notable Contributor

Marcel - sorry to hear you're experiencing a degradation of performance.  My editing experience is the direct opposite of yours.  No latency.  Immediate edits, saves, etc.  I'd recommend a call to Esri Support Services to see what's causing the slowness you're experiencing.  This is not expected behavior at all.

0 Kudos
MarcelSt-Germain
Regular Contributor

Already send packaging to support for the bugs on pfd not working anymore and for tiled label bug but, in the last case, ESRI support ask for a clipping of my projects since they do not have time to work with the full package to check why what is working before doesn't work anymore.  Same type of projects, same data.  

The problem is Pro to complex an can't do simple cartographic task anymore. 

0 Kudos
OlgunDuru
New Contributor

I have same problem with windows 11. I think  that windows 11 downgrade to windows 10. 10 is better than 11 for arcgis pro performance

0 Kudos