Select to view content in your preferred language

Map Finds Relationship Class but No Records Found

318
0
06-07-2023 11:04 AM
Labels (2)
ConnieRdz
New Contributor

Hello, 

I have a map with a Sites point layers and two related tables: Sensor Deployments and Timeseries. I also have model in ArcGIS Pro that ingest an Excel file and converts it into the Site layer and the mentioned tables. The model also creates the relationship classes (SitesHaveTimeseries and SitesHaveSensorDeployments).  The model deletes all rows from the Sites layer and tables and appends the new data. These are a hosted feature layer so when I run the model, the data is in fact updated when I check the map. Before I implemented the delete and then append, I had the map working fine and displaying the related records in a pop-up window. After I modified my model with the delete and then append to update my map, I cannot longer see the related records. It says "Records not found" but it does appear to know that there is a relationship class. If I delete the table with the relationship records, the related record content will say "Relationship not found in map".

All the related tables including the relationship class tables are in the map and I can see they have been updated. I also tried deleting the relationship class table before running the model. I tried creating a new map and same issue. I also verified in ArcGIS Pro that the relationship class was working by selecting a site and seeing the related records. I tried resharing the hosted map layer and creating a new map... I'm running out of ideas, please help! 🙃


Here's a pic of my model (hopefully it's not too small):

ConnieRdz_0-1686160420314.png

Pop-up window:

ConnieRdz_1-1686160532984.png

Pop-up settings window:

ConnieRdz_2-1686160573268.png

 

 



0 Kudos
0 Replies