Legend patch transparency after converting to graphics

254
2
11-18-2021 05:50 PM
Labels (1)
rburke
by
Regular Contributor III

Hi:

I have a layer that's actually two layers on the map - one a semi-transparent hatch fill laying under most layers and one a solid outline laying above all layers. I've added the hatch fill layer to my legend, converted to graphics, and chose a slightly lighter color without transparency for the hatch fill, and added a solid outline. Despite neither fill nor stroke having transparency, the legend patch graphics - outline and fill - show up as semi-transparent - the same value as the fill layer in the map it appears. However, these graphics don't have a global 'Transparency' slider like on the appearance tab for a feature layer. How can I remove the transparency from the patches?

0 Kudos
2 Replies
TomBole
Esri Regular Contributor

Hi rburke-bsrc,

I'm assuming that the issue is with the inability to change the transparency on the fill and outline of the graphic polygon converted from the legend.

I was able to do a quick test on 2.9 and was successful. I was able to adjust the transparency level of both the fill and the outline of the converted legend patch graphic and see the result draw on the page as expected.

I'm unaware of any similar issues that are outstanding. Can you contact Esri Support? They are better equipped to handle troubleshooting steps and gather bug data. They can be contacted at https://support.esri.com/en/contact-tech-support.

Thanks,

Tom

0 Kudos
rburke
by
Regular Contributor III

That transparency setting is working fine for me, too. It's when the transparency slider on the effects toolbar was set on the original feature layer that seems to be the problem. This slider goes away for graphics, but apparently the individual elements retain the value previously set on the layer.

0 Kudos