Layer Properties Freeze ArcGIS Pro

1086
4
Jump to solution
07-26-2023 02:48 PM
Labels (1)
allenjm
New Contributor

Hi, I am using ArcGIS Pro 3.1.2 and whenever I right click on a layer in the Table of Contents to get properties like Def Query, info, etc, it locks up Pro and doesn't display any of the properties.  The only way out is to press ESC.  Has anyone ever seen anything like this?  A side note:  This is my third computer to have this happen, so it makes me wonder if my ArcGIS profile has something that causes this.  

 

Thank you all in Advance,

Justin

 

Tags (1)
1 Solution

Accepted Solutions
ChrisUnderwood
Esri Contributor

Hello @allenjm , it sounds to me like the Layer Properties form is opening, but you can't see it. Perhaps it is hidden behind something else, or right at the edge of your screen, or on a second screen, or somewhere your PC used to have a screen ? Try changing your PC's Screen Resolution to the minimum, then the maximum, and see if the form appears.

Normal behaviour is to right-click on a Layer and select Properties, and at this point the Layer Properties form appears. If you ignore that form, then the rest of ArcGIS Pro does indeed act as if it is "locked up". Pressing ESC, is the same as pressing Cancel, and the form disappears and ArcGIS Pro operates freely again.

View solution in original post

4 Replies
ChrisUnderwood
Esri Contributor

Hello @allenjm , it sounds to me like the Layer Properties form is opening, but you can't see it. Perhaps it is hidden behind something else, or right at the edge of your screen, or on a second screen, or somewhere your PC used to have a screen ? Try changing your PC's Screen Resolution to the minimum, then the maximum, and see if the form appears.

Normal behaviour is to right-click on a Layer and select Properties, and at this point the Layer Properties form appears. If you ignore that form, then the rest of ArcGIS Pro does indeed act as if it is "locked up". Pressing ESC, is the same as pressing Cancel, and the form disappears and ArcGIS Pro operates freely again.

allenjm
New Contributor

Thank you Chris....That did it!!!!!  Sometimes it is the simplest things.....

I appreciate the help....

LacheaDeamicis1
New Contributor

I had this same issue after I used my computer on a screen projector. Resetting the Screen display back to the PC's default saved the day. 🙂

HeatherHegi1
New Contributor III

This is no doubt the issue I'm having. I'm not having any luck finding that window when changing the resolution size. This might just have to wait until I'm working from home where I have a different monitor configuration which probably caused this issue. I'd rather do that than continue troubleshooting, I don't need to access the properties that bad. This is a bug they should really get fixed.

0 Kudos