Join to feature class error

309
2
Jump to solution
09-28-2018 08:35 AM
KevinDurkee
New Contributor

I'm trying to join a table to a feature class in ArcMap. When using the join function, under joins and relates, an error comes up saying my table is not indexed. When I try to add attribute index to my table I get an error " Underlying DBMS error ODBC Driver 13  SQL server, cannot create index on view because the view is not schema bound". I've tried reformatting my data still no luck. Also tried it in Pro, same errors.  Do I need to register the table with a Geodatabase, maybe more a sqlserver error? It is an active table, would that make any difference? Any help would be great!

Thanks

Kevin

0 Kudos
1 Solution

Accepted Solutions
AndresCastillo
MVP Regular Contributor

If you are using a database view, it may not like to participate with geodatabase objects.

You might try to register the view with the geodatabase, starting at 10.5, or ArcGIS Pro.

https://community.esri.com/groups/geodatabase/blog/2016/12/14/new-at-105-registering-a-database-view...

View solution in original post

2 Replies
AndresCastillo
MVP Regular Contributor

If you are using a database view, it may not like to participate with geodatabase objects.

You might try to register the view with the geodatabase, starting at 10.5, or ArcGIS Pro.

https://community.esri.com/groups/geodatabase/blog/2016/12/14/new-at-105-registering-a-database-view...

View solution in original post

Asrujit_SenGupta
MVP Regular Contributor

Can you please share the error screenshots.

0 Kudos