Issues with Display XY Data Tool

291
4
10-08-2019 08:58 AM
Highlighted
New Contributor

I am having problems with displaying xy data from csv files in arc gis pro.

I have been using this tool to display points in a project all week (re-importing when i make edits to csv) and all of a sudden the display xy data tool is projecting all of my points on a single point despite them all having unique x and y values. They are all being actively projected as that single point is highlighted when i select any of the points in the attribute table. All the details are correct in the attribute table and the fields are mapped correctly (the same way as always).  It is not only affecting one csv but all my csv's.

I have tried reimporting the base table multiple times. recreating the csv from excel sheets. I cannot figure out what is going wrong and why all of a sudden.

I hope that someone has a clue as to why this would be happening as it is basically stopping me doing anything at the moment. 

Thanks,

Mars

Reply
0 Kudos
4 Replies
Highlighted
Regular Contributor

Hi Mars,

Is this the tool you are using?

XY Table To Point—Data Management toolbox | ArcGIS Desktop 

My hunch is that you are dealing with a coordinate system problem. Here's some questions that might help:

  • What's your output coordinate system when you ran the tool giving you the unsatisfactory result? 
  • What is the coordinate system of the map you are adding the points to?
  • What is the coordinate system of the XY locations in your CSV? Provide a screenshot if you're not sure.

Micah

Reply
0 Kudos
Highlighted
New Contributor

Hi Micah,

GCS_WGS_1984 is both the map coordinate system and the one i have been using in the XY table to point tool.

Reply
0 Kudos
Highlighted
Regular Contributor

Hmmm, that's strange. Where are the points located when you run the tool? Would you mind sharing a selection of the XY values? Are you sure that all of the points are stacked in a single location? What happens if you zoom to the output point layer?

Reply
0 Kudos
Highlighted
Esri Frequent Contributor

I have seen this with that tool when there are NULL or 0 values in the fields for the X/Y coordinates.

--- George T.