How do I add Arcgis world geocoding service to Arcgis Pro?

591
8
03-30-2020 08:58 AM
ToddOlsen
New Contributor III

I have looked at the previous entries. It shows up in my profile settings and I can manually add to each product. Put I want it to be a default in each of my new products. When I try to add the portal, the image attached is what I get:

Please help with this issue. I cannot chat or open a case to figure this out.

Thanks,

Todd

8 Replies
DonaldShaw2
Esri Contributor

Hi Todd, you are trying to add a REST Service URL to your project's Enterprise Portal list. This will not work. 

By default, the World Geocoding Service is listed under Locators

ToddOlsen
New Contributor III

sorry but it is not listed in the Locator file:

DonaldShaw2
Esri Contributor

Are you signed into a Portal / ArcGIS Online organization that has access to the World Geocoding Service?

In your ArcGIS Online organization, is the Geocoder under Organization > Settings > Utility Services ?

DonaldShaw2
Esri Contributor

Can you try this as well?

  1. Add an ArcGIS Server Connection using the following Server URL (Insert ribbon > Connections > New ArcGIS Server): http://geocode.arcgis.com/arcgis/rest/services
  2. In the Locate pane, open the Settings tab
  3. Select the "Add a Locate Provider" button and choose "Add Locator"
  4. Navigate to the Server connection and select the World geocoder.
ToddOlsen
New Contributor III

Yes I can add it to the project but I want it to always be there when I open a new project and not have to manually add it each time

Robert_LeClair
Esri Frequent Contributor

Todd - once you've added the ArcGIS Server Connection, go to the Catalog Pane -> Servers, right click on the new "services on geocode.arcgis.ags" and click "Add to New Projects."  Every new AGP you create will have this Server connection added to them.

ToddOlsen
New Contributor III

I have need added the server to every new project but I still have to manually add the world locator to every new project in the locate pane. How do I solve this?

ToddOlsen
New Contributor III

my current setting...it is there