Geocoding Address Please Help Been 5 Hours Arc GIS Pro

313
3
Jump to solution
03-19-2021 11:59 AM
Labels (3)
AliciaLowenstein
New Contributor

I just got Arc GIS Pro installed on my work computer. I have logged in to my Esri account and they are connected. This is the table I am working from. I have tried to upload as excel, every type of csv file, limiting it to only the address, sperating the street number from the city etc. and I am stumped. I've tried Geocoding Address, Geocode from Table, and I keep getting non helpful error messages. I use the Arc GIS world locating service when I input. I simply need to put these point on the map so I can see the proximity between them.

This is the error message on geocode address:

ERROR 000010: Geocode addresses failed.
Failed to execute (GeocodeAddresses).

 

This on the Geocode from table: 

https://www.arcgis.com/ is not configured with "Batch Geocode" asynchronous service.

 

Would love any form of assistance. The GIS tech couldn't figure it out either.

0 Kudos
1 Solution

Accepted Solutions
AliciaLowenstein
New Contributor

I was able to do the first step (thank you!!), but it wont let me use the ArcGIS World Geocoding Service now it says:

"Cannot use the selected locator for batch geocoding"

View solution in original post

0 Kudos
3 Replies
JayantaPoddar
MVP Esteemed Contributor

I converted the CSV to a standalone table using Table to Table.

 Right-clicked the table > Geocode Table

Here are the parameters for Geocode Table workflow.

Jayanta_Poddar_2-1616186236710.png

 

On completion,

Jayanta_Poddar_0-1616184505671.png

37 Matched and 7 tied on filtering by country (United States).

Jayanta_Poddar_1-1616186074114.png

Also check if you have enough credits to Geocode the number of addresses.

0 Kudos
AliciaLowenstein
New Contributor

I was able to do the first step (thank you!!), but it wont let me use the ArcGIS World Geocoding Service now it says:

"Cannot use the selected locator for batch geocoding"

View solution in original post

0 Kudos
JayantaPoddar
MVP Esteemed Contributor

Is your Esri account, a public account or organizational account? Batch geocoding requires an organizational account since it will consume service credits. It takes 40 credits per 1000 geocodes. Also check if you have enough credits.

More Pointers to check:

1. Are you connected to your organizational account of ArcGIS Online (through ArcGIS Pro)? 

2. Are you the administrator of the AGOL organizational account? If yes, Connect to ArcGIS Online, Go to Organization > Settings > Utility Services. Under Geocoding, do you see "ArcGIS World Geocoding Service"? 

Jayanta_Poddar_0-1616422688613.png

You need to check your privileges, if you are not the administrator.

 

0 Kudos