Select to view content in your preferred language

GeoAnalytics tools in ArcGIS Pro 1.4 fails

2859
7
01-16-2017 01:29 AM
SindreEngh
New Contributor III

We have just installed ArcGIS Enterprise with GeoAnalytics. In the Portal web map the GeoAnalytics tool is working great, but when we try to run it from ArcGIS Pro 1.4 none of the tools are working. We get the same error message for all tools CreateBuffers(), CalculateDensity() or AggregatePoints() "..got an unexpected keyword argument". Which argument this is change all the time, so it seems like the parameter format for the tools is wrong?

Do anyone get the same error, or get the GeoAnalytics tools to work i ArcGIS Pro 1.4?

Tags (1)
0 Kudos
7 Replies
SarahAmbrose
Esri Contributor

Hi Sindre,

Glad to hear you are trying out GeoAnalytics!

Can you please verify that your machines with GeoAnalytics Server installed are at least 16GB?

If not, please try using a 16 GB machine (do not install spatiotemporal data store on the same machine unless you have the required 16GB for GeoAnalytics and 16 GB for spatiotemporal data store (total 32).

If you do have a 16GB machine, can you please check if there are tool parameters are listed at the REST tool endpoint: (url similar to: http://yourGeoAnalyticsMachineName.domain.com/GeoAnalyticsWebAdaptor/rest/services/System/GeoAnalyti...)

If there are no parameters listed please restart your GeoAnalytics server through Server Manager of your GeoAnalytics Server, and try running analysis through Pro again (restart your Pro session).

If the parameters are listed, and you are still having issues please call technical support, and note this GeoNet post when you open a case so we can update it with the solution.

 

Thanks,

Sarah

GeoAnalytics Product Engineer

GaëtanLAVENU
Esri Contributor

Hi Sarah,

I have exactly the same issue. The GeoAnalytics tools runs well when called from the portal viewer, but I get the same error as described by Sindre when I try to run the tools from ArcGIS Pro. I checked the REST URL but no parameters are listed. I restarted GeoAnalytics server (and Pro) but nothing changed.

Before submitting my issue to our technical support team, I would like to check with you if you have any idea ?

Regards,

Gaëtan Lavenu

Esri France

0 Kudos
ErnstEijkelenboom
Esri Contributor

I had the same issue. Tools are not running in ArcGIS Pro 1.4 final and no parameters are listed in the REST URL.
Check if the DistributedWorker service is running. In my situation this service was stopped, even after a restart of the GeoAnalytics Server. After starting the DistributedWorker service the tools are working in ArcGIS Pro and the parameters are listed.

Another issue I have in ArcGIS Pro is trying to copy large datasets to the Spatiotemporal Data Store.
It seems that ArcGIS Pro is storing all the data first in memory before executing the Copy To Data Store tool. With small datasets (less than appr. 400k records) it works fine.
With more data (1M - 10M records) the memory consumption of ArcGIS Pro is very high (>8 Gb RAM sometimes >12 Gb!). Windows is then trying to close other programs, to restore enough memory.

Sometimes ArcGIS Pro crashed completely: Black screenw, different applications are closed. A restart of the machine is then neccessary!
Yesterday I tried it again. After more than 7 hours the Copy to Data Store tools failed with an error (see attchments).

The questions is, how can I copy data from featureclasses in a geodatabase or data in featureservices to the Spatiotemportal Data Store?

I use a ArcGIS Pro on a Windows 10 machine with 16 Gb RAM.

0 Kudos
KirstenPinkston
Esri Contributor

Hi All! Thanks for reporting your issue here. By the sounds of this issue, I'd like to suggest that you contact Support Services to continue investigating. For contact details, please see the link below:

Esri Support Contact Tech Support

If you need any help logging a ticket, please feel free to respond here and I'd be happy to help.

Thanks!

Kirsten

0 Kudos
SindreEngh
New Contributor III

We have a support case logged with Esri now, they get the same error in Pro. The case was logged one week ago.

Since this is an error that multiple users are getting, I hope this will get some extra attention

@Sarah Ambrose

Tried restaring the GeoAnalytics server, but no change.  Could you post a picture of how the REST endpoint should look like?

0 Kudos
SarahAmbrose
Esri Contributor

Thank you for submitting a support case. Please remember that no matter where (Portal, REST, Pro) you are running GeoAnalytics tools, you want to be talking to the Server/Portal/Enterprise support team. 

Sindre.Enghgeodata-no-esridist Below is an example of being able to see a REST parameter (if you do not see these, then you are running into the issue described above). The most likely cause of this is your machine does not have enough memory - it should have at least 16GB dedicated to GeoAnalytics.  
REST Parameters in GeoAnalytics

In reply to Ernst Eijkelenboom's comment, I'd also like to note that the Distributed Worker service is not related to GeoAnalytics, please do not get them confused. 

0 Kudos
GeorgeBem
Esri Contributor

I had the same issue, but I upgraded  all my Enterprise version to 10.5.1 (GIS Server, Portal, Datastore, Web Adaptor and GeoAnalytics Server) and the problem was fixed.

Regards,

George Bem