Select to view content in your preferred language

Copy Coordinates in Specific Format

766
4
10-23-2023 07:00 AM
Labels (1)
PeteJordan
Occasional Contributor III

I want to use the [Copy Coordinates] tool to copy the location in ArcGIS Pro to paste in another program.  The issue I'm having is the output in Pro contains the degrees and excludes the +/- signs.

This is how it shows in Pro (104.9833292°W 39.7263745°N )

In ArcMap it showed as (-104.9833292 39.7263745), which is the format I want.

  I have tried to change this in the Coordinate Conversion pane, but using the [Copy Coordinates] tool still outputs it with the degrees and without the - sign. 

  Anyway I can actually get this to copy it in the format I have shown below?

Coord.jpg

  I figure there has to be a simple way, but I'm just not having any luck...

Thanks

0 Kudos
4 Replies
Robert_LeClair
Esri Notable Contributor

So the way to change the Copy Coordinates formatting to +/-, go to the Project tab-Options-Project-Units.  For the Decimal Degree Location Units, left click in the Format column for Decimal Degree and uncheck the "Show direction labels" checkbox.  Click OK and OK again.  Now click the Copy Coordinates command.  What is the result?

PeteJordan
Occasional Contributor III

  Yes that helps, it does give me almost exactly what I need.  Though I still have the degree symbol which I don't want either.   Not sure if there is anything I can do about that though?

Result:
-104.8318135° 39.9715380°


  Thanks for the location of this though, I forgot to look in the Options in Pro for it...

 

-104.8318135° 39.9715380°

0 Kudos
Robert_LeClair
Esri Notable Contributor

I don't know of a way to remove the degree sign but will dig around a bit more.  One thing to do is in your third party application is do a find/replace operation.  Find the degree sign and replace with "nothing" - i.e. no space.

0 Kudos
PeteJordan
Occasional Contributor III

Yes I don't seem to find an option either as the degrees now won't work in say Google like it did with the directional one.  I have filtered out the issue anyways in the other program so it will just ignore the degree symbol and direction at least and place the - in the Long for me at least.  So the issue is fixed, but still would be nice to have that symbol removed if possible...