Clearing the cache

4353
5
Jump to solution
10-27-2021 01:17 PM
Labels (1)
SLouq
by
Occasional Contributor III

How do you clear the cache in ArcGIS Pro? I am exporting Excel spreadsheets to a folder on a network drive and then bringing the spreadsheet into an ArcGIS Pro map through ArcCatalog. However, whenever I export a new spreadsheet out to the network drive and then bring it into my ArcGIS Pro document it still says it has the same amount of attributes as the last spreadsheet. The only way I can get it to update is if I close the map document and reopen it.

Tags (2)
0 Kudos
1 Solution

Accepted Solutions
Robert_LeClair
Esri Frequent Contributor

Go to the Project tab->Options.  In the Application->Display window, check the box to "clear cache."  You'll need to restart ArcGIS Pro for this to take effect.

View solution in original post

5 Replies
Robert_LeClair
Esri Frequent Contributor

Go to the Project tab->Options.  In the Application->Display window, check the box to "clear cache."  You'll need to restart ArcGIS Pro for this to take effect.

DanPatterson
MVP Esteemed Contributor

display cache can be removed here

displaycache.png

the cache location is noted there as well

Other case info is in the help topics specific to what you want, or don't want to cache.

For example

How caching works—ArcGIS Pro | Documentation

Clear Workspace Cache (Data Management)—ArcGIS Pro | Documentation

and the list goes on


... sort of retired...
0 Kudos
SLouq
by
Occasional Contributor III

Thanks for the replies! 

0 Kudos
JayantaPoddar
MVP Esteemed Contributor

You maybe hitting a known limitation.

"Excel tables are read-only in ArcGIS Pro; however, they can be edited in Excel while you have a worksheet open in the Contents pane (stand-alone table layer). The layer will only display the updated (saved) values for edits made outside of ArcGIS Pro when ArcGIS Pro has been closed and reopened."

Could you try working with a CSV file instead?



Think Location
0 Kudos
SLouq
by
Occasional Contributor III

I'll try using the .csv file instead next time. I had had problems bringing csv files into ArcMap way back when, that's why I was converting to Excel. 

0 Kudos