ArcGIS Pro Extremely Slow after Update

1460
10
01-28-2019 12:18 PM
JasonBritton1
Occasional Contributor

Hey everyone,

I'm running v2.3.0 and performed a software update this morning (I'm assuming a patch). My software has been running very, very slow since the update, almost to the point of making it unusable. Anyone having a similar experience? 

Tags (2)
10 Replies
MichaelVolz
Esteemed Contributor

Is it running slow for existing aprxs that were created in previous versions of Pro as well as a brand new aprxs that you have started from scratch in 2.3?

0 Kudos
JasonBritton1
Occasional Contributor

Existing aprxs. I've been using Pro exclusively for about 2 years. 

0 Kudos
JonathanFarmer2
Occasional Contributor III

Hi Jason,

That update was most likely the 10.7 ArcGIS Coordinate Systems Data update. It's fairly large as far as updates go, 985 MB. I'm not aware of any patches or other updates out for 2.3 yet.

That being said, this update shouldn't cause an otherwise perfectly functioning ArcGIS Pro client to gridlock. It doesn't take up that much space in the install directory.

You might take a look at Task Manager when you open existing projects and see what's there. Do the performance issues not occur when using new projects after the update?

Jonathan

0 Kudos
JasonBritton1
Occasional Contributor

I created a new project and it seems to have fixed the issue

0 Kudos
JasonBritton1
Occasional Contributor

Yesterday I reported that the issue was fixed, but its back today. I think there was an issue with the update. 

0 Kudos
JonathanFarmer2
Occasional Contributor III

Hi Jason,

OK, thanks for letting us know. Would you be able to log a case with Technical Support on this (888-377-4575)? If this is related to a 2.3 problem, we need a record of it through a support case. They can troubleshoot the issue and, either fix it if this is specific to your install, or log a bug if this is specific to a general 2.3 issue.

Thanks!

Jonathan

0 Kudos
SeanHlousek
Occasional Contributor III

Jason,

Were you able to get your prior projects working at reasonable speeds?  I am experiencing a noticeable slowdown on all of my existing projects and creating new ones is not ideal. (Although since we cannot lock multiple layouts my projects were all bloating anyway but I don't want multiple bloated projects). 

It just took a project over 3 minutes to open with two simple layouts open. 

0 Kudos
JasonBritton1
Occasional Contributor

I couldn't get them to work at normal speed. I just added the exact same feature classes to a new project and its running fine. Weird stuff.

0 Kudos
JasonBritton1
Occasional Contributor

Just had a thought, but I didn't try it. You may be able to import your existing map frame into a new ArcPro project.

0 Kudos