ArcGIS Pro 2.8.0 freezing when editing float column in attribute table

625
6
Jump to solution
09-10-2021 02:00 AM
ChrisNewton
New Contributor II

I am using ArcGIS Pro 2.8.0 (unfortunately I'm locked to this version by our IT department, so unable to update).

When I try typing in values to a float field* in a point File Geodatabase Feature Class's attribute table, ArcGIS Pro completely freezes, requiring a forced quit from Task Manager. Weirdly, I do not experience this issue on my own laptop running the exact same version of ArcGIS Pro, even with the same project ported across on a USB stick.

I've tried fully uninstalling and reinstalling ArcGIS Pro and ensuring Windows is up to date, but the issue remains. Has anyone else experienced this, and found a way to resolve it if so?

Thanks.

*EDIT - the same issue occurs with other data types (short, long, double, data) other than text, which works ok.

ChrisNewton_0-1631264160180.png

 

0 Kudos
1 Solution

Accepted Solutions
ChrisNewton
New Contributor II

ChrisNewton_0-1631267124275.png

I've discovered a workaround since posting this just in case it helps anyone else - editing the field via the attributes pane (as opposed to the attribute table itself) while the row you wish to update is selected seems to avoid the freezing problem.

View solution in original post

6 Replies
ChrisNewton
New Contributor II

ChrisNewton_0-1631267124275.png

I've discovered a workaround since posting this just in case it helps anyone else - editing the field via the attributes pane (as opposed to the attribute table itself) while the row you wish to update is selected seems to avoid the freezing problem.

Scott_Harris
Esri Regular Contributor

@ChrisNewton

Are you sure the problem is limited to float fields? I ask because you only have 1 field in that feature class in the screenshot. Also, where is the File Geodatabase located? On the local machine in your office, on a network location? To help narrow down these types of things, you can contact Esri Technical Support: https://support.esri.com/en/contact-tech-support

0 Kudos
ChrisNewton
New Contributor II

Thanks for the reply Scott. Apologies - I have checked and can confirm the same problem occurs with all data types except text. I'll update my original post accordingly. The File Geodatabase is on my local machine in this case.

0 Kudos
Scott_Harris
Esri Regular Contributor

Ah that's very odd behavior that I haven't seen before. This blog also has lots of great tips for troubleshooting: https://community.esri.com/t5/arcgis-pro-documents/troubleshooting-performance-issues-in-arcgis-pro/......

Maybe it will be something as simple as clearing the cache (https://pro.arcgis.com/en/pro-app/help/mapping/layer-properties/how-caching-works.htm)

...if not, that's when Support can help.

0 Kudos
JeffreySimpson1
New Contributor

I have the same issue but with ArcGIS Pro 2.9.  If I click on a numeric field to edit in the table, it seems that the software is trying to expand the column to an infinite size.  Haven't entered any numbers yet.  ArcGIS Pro freezes up and I have to use task manager to exit the program.

The work around that ChrisNewton mentions works well. 

Tried clearing the cache.

 

PegGronemeyer1
New Contributor III

Has there been any progress on this? 

I've got the same issue, unfortunately the clearing cache or changing setting to clear cache after every session has not helped. I'm on Pro 2.9.3, all data are on my laptop.  I've tried exporting to a new FC as well as repairing a corrupted FC and neitehr helped. (also tried restarting Pro and computer)  

As of today it happens on multiple feature classes in multiple aprx's and on numerical, not text (at least so far) fields.  

The other thing that happens is when I click on a numerical field the field width gets huge - so wide that sometimes the field will not fit on multiple monitors.  Other times the field width increases to half the width of the monitor, but the property of field width itself does not change. 

One odd thing - I can copy and paste w/in a numeric field... but cannot type in a value.  

0 Kudos