ArcGIS Pro 2.3.2 Transparency Slider Bug

310
5
04-15-2019 04:38 PM
New Contributor III

Trying to use the transparency slider in layout view is very buggy. If I try to use slider, enter manually, or use the up/down arrows to change layer transparency the software will loose the "focus" and close the Feature Layer ribbon group. I've noticed similar behavior in other tools but the transparency slider seems to be buggier than most.

Tags (1)
5 Replies
New Contributor II

Hi Ian

We have been having the same issue consistently. I suspect that your bug is related to this bug https://community.esri.com/ideas/16486-symbology-deselect-23-bug .

If you work out a solution please let me know. It's getting quite irritating.

Reply
0 Kudos
Esri Regular Contributor

Ian & Harvey, 

I agree that having to refocus the application can be irritating. We are working to correct erroneous focus shifting when working in the Layout View for the 2.4 release.

In the meantime, if the shifting focus becomes intolerable, you may want to consider working within an activated Map View when making changes to layers. To do this right-click the map frame on the Layout View you want to work with and click Open. This opens a Map View of the map (contained by the Map Frame). You can dock the Map View Next to Layout View to see both. Make the Map View the active view when you make changes to your layer(s). The layout will update automatically with these changes.

Please note that the extents of the Map Frame and the Map View are NOT linked. If you wish to apply an extent that you have in a Map View you can create a bookmark. You can then use the bookmark in the Layout View. The bookmark will be applied to the current default Map Frame. If you have multiple Map Frames the current default will be the one in bold the Contents pane. To change the current default select the Map Frame you want, then apply the bookmark.

Here are some help topics you might find useful.

https://pro.arcgis.com/en/pro-app/help/layouts/work-with-a-map-on-a-layout.htm

https://pro.arcgis.com/en/pro-app/help/mapping/navigation/bookmarks.htm

Hope this helps, 

Tom

Reply
0 Kudos
New Contributor III

Thanks Harvey and yes I'm experiencing the same behavior. Agree with the irritation level. At this point I am not going to use Pro for production work until a more stable version is available. 

Reply
0 Kudos
New Contributor II

Was this issue supposedly resolved? I'm having the same issue with Pro 2.6.2, and it's very annoying.

Reply
0 Kudos
Esri Regular Contributor

Hi Ryan, 

As far as I'm aware many of the shifting focus issues I alluded to in my comment of 4/17/2019 have been addressed.  I'm unware of any outstanding issues concerning the use of the Transparency slider (Feature Layer Appearance tab on the ribbon) in the Layout context.  I've tested with 2.6.2 and ArcGIS Pro was working as I expected.

That does not mean you are not running into a bug. It just means I currently do not have steps to reproduce the bug.  Can you contact Esri Support? They are better equipped to handle troubleshooting steps and gather bug data. They can be contacted at https://support.esri.com/en/contact-tech-support.

Thanks, 

Tom

Reply
0 Kudos