Select to view content in your preferred language

Another ArcGIS Pro Conda/Python/Spyder post

08-21-2018 08:06 AM
MVP Emeritus

I've been fighting the cloning issue since upgrading to ArcGIS Pro2.2 back before the UC.  At one point I down graded back to 2.1.  However, I'm happy to finally say I've gotten past all of it.

At any rate, I had escalated a case with ESRI Tech support and today (actually last night) I received a set of instructions that actually solved the problem(s) I've been experiencing:

1) Delete C:\Program Files\ArcGIS\Pro\bin
2) Rename C:\Users\{User}\AppData\Local\ESRI\conda to conda_old
3) In your registry (regedit) rename HKEY_CURRENT_USER\Software\ESRI\ArcGISPro  to ArcGISPro_old
4) Repair the software
5) Test if the issue still exists

All of these steps (except #5) need admin rights to the machine in question, and after running them, I have successfully made a clone of the default environment that is currently active in ArcGIS Pro.

While I'm still not thrilled with the need for cloning environments, I've added the packages I want to my clone and feel like I'm good to go....

That should just about do it....
0 Replies