Select to view content in your preferred language

3D Object Heights Are Miles High Despite Being Set to Feet

521
3
08-14-2023 09:22 AM
Labels (1)
NormBetland
Occasional Contributor

I'm at a total loss. I have a layer with a few basic objects. All the objects are under 75 feet high. In the elevation settings tab for the layer properties I have these objects set to relative to ground, the height field selected for the z-value, the units set to USFeet and yet these objects are rendering as being tall enough to probably reach low earth orbit. The objects are also not even close to rendering their heights relative to each other either. One of the shorter objects is rending about 20 times as tall as the tallest object.

I'm at a total loss as to what the solution is.

3 Replies
DanPatterson
MVP Esteemed Contributor

Can you examine the field to make sure that there aren't any anomolous values.

Open the table in Fields view and report what the units etc are set too.

What is the coordinate system of the data?


... sort of retired...
0 Kudos
NormBetland
Occasional Contributor

All of the values were between 20 and 60. Units were set to US Feet. Coordinate system is Minnesota State Plane North.

0 Kudos
Prab
by
New Contributor II

NB are you still having an issue:

Quick check.  It sounds like you are displaying(symbolize) objects using extend Z by multiplying your AGL (above ground level) fied with a number say 100.....Easy check by going to symbology and seeing if extend Z option selected.  If not then This is all in the SCENE viewer window in arcPRO 3.0>>Is your object layer a feature class 'z' value?...if not interpolate point to raster (dem).  now you have x,y, z objects.  All distances are meters including elevation.   I'll come back to this..   just to add to DP's answer...check your feature's projection and coordinate system.  If no defined projection...then reproject to a distance measurable projection, usually some type of mercator.  So if large scale use UTM zone (#based on longitude  + and - 3 degrees) .   MAke sure your elevation and feature layers are in same projection.    Try Properties ELEVATION > Elevation to feature's Z value (or something that indicates the 'z' value) of your objects.  make sure you don't have a vertical exaggeration value and cartographic offset value .. highlight your object layer and select 'zoom to layer'.    if still don't see turn off any polygon layers one at a time sometimes they will appear under the ground level elevation file / data .  if still unable to see zoom out slowly and tilt / swiviel slightly to see if  above ground elevation dem...if seen still high click info on elevation dem where point falls in 2d map window.   make sure the pixel has a value and it changes correctly.    If able to find objects in scene window please reply

 

Tags (3)
0 Kudos