3D extruded polygons flickering

4069
19
Jump to solution
02-19-2016 08:35 AM
SteveCline
Occasional Contributor

I am new to ArcGIS Pro but would like to use it to create a local 3D scene using a vector shapefile where polygons are extruded based on an attribute.  I have tried several different feature classes and I am getting the same result in every case.  The features are "flickering" when viewed in 3D.  Here is a screenshot:

Any suggestions are appreciated.

Steve

1 Solution

Accepted Solutions
JeremyWright
Esri Regular Contributor

This isn't anything wrong with your graphics card or ArcGIS Pro.

The polygons are "z-fighting" with the ground surface.  This is expected, and you can repro in ArcScene even by stacking a world-extent polygon with extruded polys with a small extrusion value. 

The graphics card can't decide which polygon is on top (ground or the extruded polys) when their values are very close to each other.

To prevent them from z-fighting, the polygons can be OFFSET from the "Ground" (using "relative to ground") by some amount.  Alternatively you can add MORE extrusion to ensure that the polygons' tops are "Above ground".

Z-fighting is pretty well explained here if you're feeling like reading more about it: Z-fighting - Wikipedia, the free encyclopedia

View solution in original post

19 Replies
DanPatterson_Retired
MVP Esteemed Contributor

Just to make sure it isn't a video thing, did you run the system check?

ArcGIS Pro system requirements—ArcGIS Pro | ArcGIS for Desktop

And apparently emulating the video driver isn't the same as having the actual one (but I can't put my hands on the link)

SteveCline
Occasional Contributor

After checking the requirements I found no issue as the computer I was using met all the minimums.  This morning, I updated to 1.2 and the flickering went away.

0 Kudos
DanPatterson_Retired
MVP Esteemed Contributor

maybe you can find it on the what was fixed list Release Notes for ArcGIS Pro 1.2—ArcGIS Pro | ArcGIS for Desktop

There is also one for 1.1.1 (don't mind the link title)

Release Notes—ArcGIS Pro | ArcGIS for Desktop

and 1.1.0

Release Notes—ArcGIS Pro | ArcGIS for Desktop

JeremyWright
Esri Regular Contributor

This isn't anything wrong with your graphics card or ArcGIS Pro.

The polygons are "z-fighting" with the ground surface.  This is expected, and you can repro in ArcScene even by stacking a world-extent polygon with extruded polys with a small extrusion value. 

The graphics card can't decide which polygon is on top (ground or the extruded polys) when their values are very close to each other.

To prevent them from z-fighting, the polygons can be OFFSET from the "Ground" (using "relative to ground") by some amount.  Alternatively you can add MORE extrusion to ensure that the polygons' tops are "Above ground".

Z-fighting is pretty well explained here if you're feeling like reading more about it: Z-fighting - Wikipedia, the free encyclopedia

View solution in original post

JeremyWright
Esri Regular Contributor

you could also set the ground surface color to fully transparent.  You can do this in Map properties->Elevation Surface.  Set the color picker to "no color" and hit OK.

0 Kudos
SteveCline
Occasional Contributor

Jeremy -

I appreciate the response and suggestions here.  Since this reply was posted I updated ArcGIS Pro and the issue is now resolved.  Apparently someone was working on this somewhere.

Thanks

Steve

0 Kudos
JeremyWright
Esri Regular Contributor

We made some changes to default options on some layers, so perhaps that resolved the issue. 

0 Kudos
JoãoMartins4
New Contributor

Hi Steve and Jeremy,

I´m having a similar problem, 3d extruded polygons flickering, 2 years later... ArcGISPro 2.1.3 

I don´t think this is z-fighting though. I checked the system requirements, passed the test. The only thing short maybe the graphics card with only 1Gb memory (AMD FireProV5800).

extruded poligons 3d flicker

What can I do?

Thank you.

João

NoelPeterson
New Contributor III

Same issue here. I also have a 1GB graphics card (AMD Radeon HD 7450). Not only do the polygons flicker, but the awful flickering polygons take forever to render in the first place. Quite infuriating. 

0 Kudos