Do Not Sort Coded Value Domains Alphanumerically in Attribute Table Pull-Down Menus

599
4
05-28-2021 01:00 PM
Status: Implemented
Labels (1)
NathanHeickLACSD
Occasional Contributor III

I'm developing a file geodatabase schema and I noticed that my domains are sorted alphanumerically in the Attribute Table pull-down menus, but they are in my desired order in the Domains view.  Please do not force the order to be alphanumeric.

Tags (1)
4 Comments
NathanHeickLACSD

This also applies to the Select by Attributes command.  You are essentially making a decision that alphanumeric is better than what the database administrator set in the domain for the order of the coded values.  In addition, I seconded the ideas for providing more options to manipulate the domain order in the Domains view.

KoryKramer
Status changed to: In Product Plan

This was noted as https://support.esri.com/en/bugs/nimbus/QlVHLTAwMDA5ODIxMw== which is showing as fixed in ArcGIS Pro 2.9 - so updating this status to In Product Plan.

KoryKramer

For the comment about Select by Attributes - here is what I see in 2.7.3:

KoryKramer_0-1622564648357.png

Here is what I see in a dev build of 2.9:

KoryKramer_1-1622564693776.png

 

KoryKramer
Status changed to: Implemented

As noted in previous comments, this was treated as a bug rather than an idea, which allowed for it to be addressed in a patch.  This is fixed in ArcGIS Pro 2.8 Patch 2 (2.8.2).

KoryKramer_0-1628189687509.png

Select by Attributes:

KoryKramer_0-1628189828601.png