Consistent and flexible roudning in chart R2 values

650
5
02-12-2021 09:52 AM
Status: Open
Labels (1)
JuneSkeeter
New Contributor II

When working with the chart plots in layout view, the R2 value rounds inconsistently (sometimes to the tenth, sometimes to the hundredth).  Further, it rounds the values incorrectly in some circumstances.  Eg.  it rounds 0.05678149532 to 0.06 in the chart tab, but shows it as 0.07 on the map?

JuneSkeeter_0-1613152062771.png

 

JuneSkeeter_1-1613152268353.png

 

 

Tags (3)
5 Comments
KoryKramer

Hi @JuneSkeeter Thank you for submitting this idea.  For the comparison that you are making between the r-squared value in the chart vs. the r-squared value in the chart frame in the layout, have you unchecked the property to 'Only show chart data that is visible in the map frame'

https://pro.arcgis.com/en/pro-app/latest/help/layouts/charts.htm#ESRI_SECTION1_460C164465B54CE6B9906...

If the map frame is not displaying all of the data, then the data used in the chart frame will be a subset of the full dataset by default.

KoryKramer_1-1613165848428.png

 

KoryKramer_0-1613165770380.png

Hopefully that helps explain that part.  If it resolves the inconsistency you're describing, could you please remove that from the idea as it makes it sound more like a bug than an idea?  Thank you.

So now for the idea, could you please add some detail about what you are looking for?  It sounds like you would like to be able to control the r-squared display, correct?  You would like to be able to control whether r-squared shows tenths, hundredths, thousandths, and control rounding options?  Please add some more detail about what you would like to see.

Thank you!

 

JuneSkeeter
Hi,


It is both a bug and a request? I contacted ESRI support and they were unable to address my issue and told me to post here.


1) Yes, control over rounding would be nice (tenth vs. hundreth) would be nice for consistency sake if for instance I'm trying to show two plots.


2) I can confirm that zooming does change the R2 values displayed on the chart layout pane (First vs. Second Screenshot). Unchecking "Only show chart data visible in the map frame" does resolve this (Third screenshot).

- However, if I click Filter by extent in the Chart pane (Fourth screenshot) there is still an inconsistency in the way the R2 value is displayed in the chart window vs the chart layout. So its unclear which R2 value I should "trust"?


[cid:fd4dabc2-854d-488a-a93f-afb02995ad08]


[cid:b60d3fa1-149a-487f-a9ed-a3dd896e3296]


[cid:c70886f2-ed78-4d57-8220-0ae86dac04e0]

[cid:7917721d-8f65-47b2-8eb2-d2ed48f41fb7]

KoryKramer

Thanks @JuneSkeeter 

As far as I can tell there isn't a bug here.  But if you feel there is, you can certainly pursue that through the open case with Technical Support.

"Unchecking "Only show chart data visible in the map frame" does resolve this (Third screenshot)."

Excellent!

"However, if I click Filter by extent in the Chart pane (Fourth screenshot) there is still an inconsistency in the way the R2 value is displayed in the chart window vs the chart layout. So its unclear which R2 value I should "trust"?"

Unfortunately your screenshots did not come through so I'm unable to see what you're referring to.  I think that *maybe* I understand what you're talking about...  take a look at this quick video walking through how the filtering will work depending on what map/view/frame is active: Chart Filtering

Does that help?

JuneSkeeter
Hi Kory,
 
It does clarify things a bit.  But I still think there is something weird going on?  I've attached a short 2.5 min screen share highlighting the issue/confusion?
 
Tech support has followed up w/ me again as well so I'll pass the video onto them as well.
 
Thanks,
KoryKramer

Thanks for the video.  That helps.  I don't have an immediate explanation for the difference in value you are seeing between the chart frame and the chart.  I am not able to reproduce that behavior using my data.  Please continue to work on this through technical support.

 

Thank you.