Token Required when going to hosted layer service URL

632
3
Jump to solution
11-03-2022 12:50 PM
Labels (1)
MelissaGearman
New Contributor II

When I go to the URL on a hosted items detail page, the page that comes up only says Token Required. For the moment, I'm simply just trying to get the data in JSON format using the URL formats shown in get feature layer data:

https://developers.arcgis.com/documentation/mapping-apis-and-services/data-hosting/hosted-feature-la...

I've been able to get feature layer data in this format before but I've never attempted it with a hosted layer. The internet has given me a variety of solutions but nothing has worked so far.

MelissaGearman_1-1667504196985.png

Any suggestions and/or a clear explanation on what is happening would be very much appreciated.

Thanks!

 

1 Solution

Accepted Solutions
RhettZufelt
MVP Frequent Contributor

Try this route.  Open the item details page and click on the View link at the URL:

RhettZufelt_0-1667519175622.png

Then, right click on the new link that comes up and open in new window or tab:

RhettZufelt_1-1667519204951.png

 

This will actually take you to the REST server with the token in the link.  There should also be an Admin link in the upper right of this page if you need it.

R_

View solution in original post

3 Replies
RhettZufelt
MVP Frequent Contributor

Try this route.  Open the item details page and click on the View link at the URL:

RhettZufelt_0-1667519175622.png

Then, right click on the new link that comes up and open in new window or tab:

RhettZufelt_1-1667519204951.png

 

This will actually take you to the REST server with the token in the link.  There should also be an Admin link in the upper right of this page if you need it.

R_

marjorie_jerez
New Contributor III

This was a life saver today, thank you! 🙂

0 Kudos
MelissaGearman
New Contributor II

Thank you Rhett! This worked!

0 Kudos