Some polygons not showing when zoomed out

02-01-2022 03:11 AM
Labels (1)
New Contributor III

I have a polygon layer in the new map viewer in AGOL. When I'm zoomed out to country level, some of the smaller polygons disappear. It's like the map viewer is automatically clustering or generalising the polygons. I've got visible range set as World to Building, and I don't have any effects turned on that I can see. I don't get any error messages about having too many features either.

It doesn't happen in the classic map viewer, so is this a new feature on the new map viewer? Is there a setting somewhere I'm missing to control this? When zoomed right out, I still want to see all polygons because the overall distribution and number of polygons is important. The workaround I have been using is to create a point layer that shows all locations when I'm zoomed right out, then set the visible ranges of the two layers to change to polygons as I zoom further in. However I'd prefer not to have to do this.

0 Replies