'Show item details' problem

628
2
Jump to solution
03-27-2019 06:17 PM
PeterSmith3
New Contributor III

I've created a web map and a web mapping application (based on the web map), and shared them publicly.

The map contains some hosted feature layers and when I click to show a layer's item details, from the map, I get taken to the correct overview page. However, trying to view the same layer's item details, via the app, I am asked to enter my login details. Can anyone explain why this is so?

Map link: https://www.arcgis.com/home/webmap/viewer.html?webmap=dd3ca3fb4f3240a7aed0dae78a41fada

App link: https://fba.maps.arcgis.com/apps/webappviewer/index.html?id=9aa3cb4963ba459d8b539bceb43e8761

An example problem layer is 'Fitzroy Subcatchments'.

The only difference that I can see is that the map's address starts with 'arcgis.com', where the app address starts with 'fba.maps.arcgis.com'.

How do I resolve this problem? Some of the other feature layers contain important caveats, and it is necessary for any user to be able to access this detail.

0 Kudos
1 Solution

Accepted Solutions
KellyHutchins
Esri Frequent Contributor

It looks like your organization has access set to private so only members of the organization will be able to access the content via the organization url. If you have public content (like the Fitzroy Subattachments) layer you want non-org users to access then you'll need to view that content via the 'www.arcgis.com url. 

The easiest way to 'fix' this in your app is to share your app with the arcgis.com url. If you do this then the item details will be opened via the arcgis.com url.

You can see the behavior here: 

https://www.arcgis.com/apps/webappviewer/index.html?id=9aa3cb4963ba459d8b539bceb43e8761

View solution in original post

2 Replies
KellyHutchins
Esri Frequent Contributor

It looks like your organization has access set to private so only members of the organization will be able to access the content via the organization url. If you have public content (like the Fitzroy Subattachments) layer you want non-org users to access then you'll need to view that content via the 'www.arcgis.com url. 

The easiest way to 'fix' this in your app is to share your app with the arcgis.com url. If you do this then the item details will be opened via the arcgis.com url.

You can see the behavior here: 

https://www.arcgis.com/apps/webappviewer/index.html?id=9aa3cb4963ba459d8b539bceb43e8761

PeterSmith3
New Contributor III

Thanks Kelly, your answer resolves my problem and I'll be using that solution.

However, I'm still a little confused as to why this happens.

When I do public searches, i.e. not signed in, on ArcGIS.com, I get the following results:

Search result for feature layer: 'View item details' takes me to the ArcGIS.com 'Overview' page; 'Open in Map viewer' takes me to a new ArcGIS.com map with the feature layer loaded.

Search result for web map: 'View item details' takes me to the ArcGIS.com 'Overview' page; 'Open in Map viewer' takes me to the ArcGIS.com map. From the map, 'Show item details', for the above feature layer, takes me to the ArcGIS.com 'Overview' page.

Search result for web mapping application: 'View item details' takes me to the ArcGIS.com 'Overview' page; however, 'View Application' takes me to the fba.maps.arcgis.com page (the app opens even though I'm not signed in); From the app, 'Show item details', for the above feature layer (from the above map), takes me to the FBA login page.

So the only time that there's a problem is when trying to view the feature layer's item details from the app. Removing the 'fba.maps.' text from the app's url gives me the access I need, which is great.

However, I don't understand why, if the feature layer and web map use ArcGIS.com, the web mapping application uses fba.maps.arcgis.com (while the app's 'Overview' page also uses ArcGIS.com)?

Thanks.