"Unavailable Layer"???

333
5
09-05-2018 09:36 AM
TimHoeflich
New Contributor II

I have two "Feature Layer (hosted)" in my account that will no longer appear.  If I open a storymap that uses them, or if I attempt to view them from inside AGOL, I get the same message "Error The layer, Destinations, is not available and cannot be added to the map."  What is going on?

Tags (1)
0 Kudos
5 Replies
MichaelVolz
Esteemed Contributor

When was the last time you were able to use the HFLs?  There were issues with AGOL HFLs yesterday, so hopefully that did not corrupt your layers.

ArcGIS Online Health Dashboard 

The status history on this page shows the issues on Sep 04.

0 Kudos
TimHoeflich
New Contributor II

I've had a AGOL account for about 1.5 years.  Haven't encountered this yet.  How can I tell if the data is corrupted?  Stranger still, I can add these HFL to a map in ArcGIS Explorer Destop ((3400) and they read fine.

0 Kudos
KellyGerrow
Esri Frequent Contributor

Hi Tim,

Are you still experiencing the issue?  The issue from yesterday is resolved so there shouldn't be any remnants. I'd suggest giving a quick browser cache clear incase of saved responses in your browser, but if the issue is still on going, please get in touch with tech support and share the layer and web map.

Thanks,

Kelly

ChristopherSchreiber
Occasional Contributor II

I don't know if Esri uses Azure to host feature services, but Azure's South Central Data Center experienced major issues yesterday and is still recovering. If Esri hosts with Azure, this may be why. 

Azure status 

Chris

KellyGerrow
Esri Frequent Contributor

A summary of the issue from yesterday:

Thank you for your patience as we worked through performance and publishing issues with certain ArcGIS Online hosted features layers yesterday.   We understand the urgency and importance of continuing to provide a resilient, redundant and well architected system and we are confident that everything is back to normal and no data was lost.

 

What happened:

Between 3:00AM and 6:45 PM PST Tuesday September 4, 2018 ArcGIS Online experienced continual intermittent problems with a subset of our infrastructure that provides hosted feature services and spatial analysis. 

 

Why did it happen:

The issue was due to a weather/lightning event which caused electrical problems and a shutdown of part of the infrastructure with the Microsoft Azure South Central US region. This infrastructure shut down resulted in a subset of ArcGIS Online Services being unavailable for publishing or viewing.

 

Our Response:

The ArcGIS Online operations team worked with Microsoft Azure during the event to diagnose the problem and then began work on swift recovery.  During the investigation and recovery, the status of the issue was updated at status.arcgis.com until restoration was verified and tested.  In parallel to the above activity we also triggered our Disaster Recovery process for restoring affected services in a different region from database backups.  The recovery of the original affected data center completed earlier.

 

Additional notes and plans:

  • Our services already run in High Availability mode covered by the SLA of Azure and take advantage of redundancy and fail over across multiple instances. We will investigate and consider additional improvements once the root cause analysis from Microsoft has been released to strengthen the availability of our current deployments. 
  • We will also look at improvements to the communication process to insure you have the most reliable and updated information possible.
0 Kudos