Publishing Geocoded Points to AGOL

136
5
Jump to solution
08-13-2020 07:17 AM
JoeBorgione
MVP Esteemed Contributor

ArcGIS Pro 2.5.1

I've geocoded a number of tables into point feature classes; nothing new for me.  However, when I publish the results to AGOL, I get one of several errors when I perform the Analyze step.  Sometimes I have to make the locator name field visible, other times, it's the place name field, and some other times it's street name field.  I don't remember what locators I used, but it just seems odd, if not silly to me that these fields need to be turned on in order to publish.

can't wait to retire....
0 Kudos
1 Solution

Accepted Solutions
JonahLay
Esri Contributor

A field that is selected as the Display field must be visible. Analyzer 00212 appears if the field ("StName" in your case), previously set as the Display field, is not visible.

If you navigate to your Layer Properties -> Display, and set a different Display field, the analyzer should not appear.

Hope it helps,

Jonah

View solution in original post

0 Kudos
5 Replies
JonahLay
Esri Contributor

Hi Joe,

I'm assuming that you are sharing a web feature layer? What errors do you get when you click on Analyze? 

Jonah

0 Kudos
JoeBorgione
MVP Esteemed Contributor

Yes, I'm publishing to a web feature layer.  As mentioned, the errors vary  based on the fields I've turned off in the geocoded results feature class class. Here's one:

00212: Display field must be visible—ArcGIS Pro | Documentation ; it's no big deal to make it visible, more of an irritation;.I try to keep my feature layers to a minimum with respect to fields as I never know who is going to be looking at the data.

can't wait to retire....
0 Kudos
JoeBorgione
MVP Esteemed Contributor

Here is another with the geocoded points fields in the backgorund:

can't wait to retire....
0 Kudos
JonahLay
Esri Contributor

A field that is selected as the Display field must be visible. Analyzer 00212 appears if the field ("StName" in your case), previously set as the Display field, is not visible.

If you navigate to your Layer Properties -> Display, and set a different Display field, the analyzer should not appear.

Hope it helps,

Jonah

View solution in original post

0 Kudos
JoeBorgione
MVP Esteemed Contributor

Ahhh... I see. Okay. That explains the randomness of it.  Thanks for the explanation!

can't wait to retire....