Publish Tiles Automatically - Grayed Out not selectable

423
2
04-16-2019 04:13 PM
EricPescatore
Occasional Contributor

Currently i am attempting to publish a Tile layer from a hosted feature Service (Note all services are hosted in AGOL). Yet when attempts are made to generate tiles automatically i find the option to be grayed out completely and only.

The layer i am attempting to use is a freshly minted Feature Service from a Geodatabase. Nothing seems out of the ordinary. 

A second layer which I've published else where does allow the generation of tiles automatically. There is no rime or reason as to why it would be grayed out.

According to the Help document and the blog post this should be a straight forward endeavor. 

https://community.esri.com/community/gis/web-gis/arcgisonline/blog/2017/07/06/arcgis-blog-publishing...

The layer I am publishing is simply a POINT Feature class, and the example one which does have dynamic tiling enable is a similar data set. Unless it needs to be published from a hosted view. But I've tried a variety of different formats.

The difference between the two layers would be that one (That is grayed out) was published right from ArcMap 10.6 while the other was a layer generated by Survey123 as a feature service. Unless there some behind the scenes bs happening that defines these two layers differently I am at a loss. As the "Create Tile Automatically" button which should be visible when you 

CLICK FEATUER SERVICE DESCRIPTION > PUBLISH > TILE 

Does not even appear. Will try to publish the data from a uploaded zip geodatabase. 

Has anyone else encountered this? I Believe the March/April AGOL updates may have done something wiggy to things.

Is there perhaps some other hidden requirements to have it enabled?

0 Kudos
2 Replies
EricPescatore
Occasional Contributor

Interesting enough Pushing the a zip geodatabase has the Create Tiles automatically visible, so I do have my solution. But not sure if this is a bug or something set incorrectly in ArcMap when publishing will "break" the option. Will test in pro later.

0 Kudos
EricPescatore
Occasional Contributor

Upon further review, Labels were the reason why. Labels cannot allow for dynamic tile creation, the moment you save your feature service or publish it from arcmap with labels on will disable the feature.

https://doc.arcgis.com/en/arcgis-online/manage-data/manage-hosted-tile-layers.htm#GUID-132E3DD5-83E3...

 

Gonna close this tomorrow, unless anyone got something else to add