operational dashboard data filter

353
5
Jump to solution
10-09-2019 05:18 PM
Highlighted
New Contributor II

When saving my operational dashboard in edit mode, no data is filtered and I see all records on the map, but when I open the saved application my data is filtered.  Why is this different from my design view, and how can I find the component that is filtering my data  

Reply
0 Kudos
1 Solution

Accepted Solutions
Highlighted
New Contributor II

Peter,

Thanks for taking the time to help me debug my problem!  The problem was definitely with the ...Fieldworker Feature Layer (hosted, view) created from the original Feature Layer. I could not find any filters is this layer view definition, so I ended up recreating the dashboard using the source Feature Layer and that solved the problem - Operations Dashboard for ArcGIS 

Thanks Again!

View solution in original post

5 Replies
Highlighted
Esri Regular Contributor

HI NSGIC Organization‌,

I'm wondering if you have any selectors configured in the dashboard? Per the documentation selectors will not filter data until you save and use the application. Another possibility is filtering on the Hosted Feature Layer (Item Details > Visualization > click Filter beneath the layer) - I would investigate this as well.

Hope this helps,

-Peter 

Reply
0 Kudos
Highlighted
New Contributor II

I've checked everything I can think of but still not luck - only 10 of 13 records are available - 3 disappear.

Here is a link to the Operations Dashboard for ArcGIS  

Here is a possible clue:  I made a copy using "save as" and when I opened the link for the copy all records appeared.  I then shared the copy with everyone and when I open the link again, the 3 records disappear again. 

I've looked at the data and see no filter or selection or reason why these 3 records are different. Link here...

https://services5.arcgis.com/fmKivMCp6fwbWbeE/arcgis/rest/services/survey123_cf4b4ab7d3d248dbb2330d3... 

Reply
0 Kudos
Highlighted
Esri Regular Contributor

Hi NSGIC Organization,

Thanks for the description here. The link you sent me to the service is of a Fieldworker feature layer view, created from Survey123. If you examine the view definition in ArcGIS Online, is there anything configured there? You might see a filter there that is removing the three records (OIDs 8,10 and 14).

These three records are in the Feature Service. Since the Feature Service is public, can you use this in Operations Dashboard?

Hope that helps,

-Peter

Reply
0 Kudos
Highlighted
New Contributor II

Peter,

Thanks for taking the time to help me debug my problem!  The problem was definitely with the ...Fieldworker Feature Layer (hosted, view) created from the original Feature Layer. I could not find any filters is this layer view definition, so I ended up recreating the dashboard using the source Feature Layer and that solved the problem - Operations Dashboard for ArcGIS 

Thanks Again!

View solution in original post

Highlighted
Esri Regular Contributor

Glad the issue is resolved and happy to help!

Reply
0 Kudos