New Map Viewer Chart Widget displays numbers instead of Dates

828
5
Jump to solution
03-08-2022 06:24 AM
DanielShaffer2
New Contributor III

Hi, Everyone!

I'm sure this is simple but I cannot find an exact match to my question.

I have water sampling data that includes a collection date. I can make bar and line charts of various parameters but in the (New) Map Viewer, those dates display as integer values. See attached image. The field is definitely "Date" type. It displays correctly in the OLD Map Viewer. Display Time is turned off, though the date values don't have a time anyway (and the problem was the same).

Is there a simple setting somewhere that I am missing? Do I need to do some type of conversion on the field so that the Chart Widget in the new Map Viewer reads it correctly? Or, is this an OS/Browser/Font-type issue?

Thanks in advance for any help or direction.

0 Kudos
1 Solution

Accepted Solutions
LaurenBallantyne
Esri Contributor

@DanielShaffer2 Thanks for the map, definitely helped me figure out what your workflow was. What you're seeing looks like a bug in applications using the 4.x js-api, so I've submitted a ticket for it to be fixed. Thank you for bringing this to our attention!

Unfortunately, there isn't a workaround for this in the new Map Viewer right now, but you should see your dates formatted properly by the User Conference Release at the end of June.

View solution in original post

0 Kudos
5 Replies
DanielShaffer2
New Contributor III

Image attached this time?

CRPA_ChartDate_Issue_20220308.jpg

0 Kudos
LaurenBallantyne
Esri Contributor

Hi Daniel,

Thanks for the question. Are you able to provide more detail on how the data was collected and how you configured the pop-up? A sample map would also be really helpful so that I can get a better understanding of what is going on here.

Pop-up charts only allow numeric fields, integers and doubles, to be passed in to populate the chart, so I'll need a bit more context in order to help you out. 

0 Kudos
DanielShaffer2
New Contributor III

Thanks, Lauren!

https://abra.maps.arcgis.com/apps/mapviewer/index.html?webmap=5f0a0c0696bb430f9f1ed29e9a23f9bd

It seems unlikely to me that one could not show a chart of values collected at different dates:

"Pop-up charts only allow numeric fields, integers and doubles, to be passed in to populate the chart"

The old Map Viewer shows them perfectly.

Again this occurs first in the new MapViewer. If I then open the map up in the OLD MapViewer, I also see the same problem. I must then remove and recreate the charts in the old MapViewer to get it to read the date correctly.

Perhaps it is important to note that the chart is built using values from a related table. I'm still learning how to use related tables (and Arcade in general), so it's likely that I'm doing something that is very simple the wrong way...or a more difficult way!

I have since seen in the Attribute Table information option that the viewer thinks the data type and description are not set for the Collection_Date field. I absolutely created that field as a Date in the GDB that I uploaded. Also, I don't see a way to set or change those settings in AGO.

Happy to answer any more questions. Thank you for the help!

 

0 Kudos
LaurenBallantyne
Esri Contributor

@DanielShaffer2 Thanks for the map, definitely helped me figure out what your workflow was. What you're seeing looks like a bug in applications using the 4.x js-api, so I've submitted a ticket for it to be fixed. Thank you for bringing this to our attention!

Unfortunately, there isn't a workaround for this in the new Map Viewer right now, but you should see your dates formatted properly by the User Conference Release at the end of June.

0 Kudos
DanielShaffer2
New Contributor III

OK well, we'll just have to leave everything in Map Viewer Classic for now then.

Thanks for your help!

0 Kudos