My location tool on a mobile device

570
4
Jump to solution
01-04-2017 08:16 AM
WesMiller
Regular Contributor III

At one time there was a my location for ArcGIS Online maps that appears to be missing now. Is there some field that needs to be toggled\enabled to turn my location back on? The tools location was where the red line has circled and was only on when the map was used on a mobile device.

 

 

Reply
0 Kudos
1 Solution

Accepted Solutions
KellyGerrow
Esri Frequent Contributor

Thanks for posting the links.

It looks like the pellet plant trails service that you have added to your web map, and then consume in the app is enabled for http only: http://gis.cityofflorence.com/arcgis/rest/services/PeletPlantTrailsWebMap/MapServer 

When you call the app using https, a secure connection can not be made with this service as this has not been enabled on the service, causing it to fail to load. In order to use https for your app, you will need to discuss the possibility of enabling ssl/https on the server hosting your service.

-Kelly

View solution in original post

4 Replies
KellyGerrow
Esri Frequent Contributor

Hi Wes,

Are you accessing this web map or app through http or https? Some browsers will still support accessing the geolocation API services through http, while many browsers require https.

This blog explains this in further detail: Increased web API security in Google Chrome | ArcGIS Blog 

Check out my response to in the following post for more details https://community.esri.com/message/640696-location-on-mobile-devices-on-geoform?sr=search&searchId=1...

If you are using https, can you share the link to the app or map?

-Kelly

WesMiller
Regular Contributor III

Kelly thanks for your response. I was accessing with a web map using http. On my older sites changing http to https does put the my location back on the map, however it zooms to close to the location to be useful.

I've been following the instructions to create a web app with the my location widget. I'm now encountering a different problem.

Without the 's' the map shows fine with widget not working

http://florencesc.maps.arcgis.com/apps/webappviewer/index.html?id=4a78b1580a434883af9fa973225e33a4‍

When I add the 's' the app can't load the map service but the widget works

https://florencesc.maps.arcgis.com/apps/webappviewer/index.html?id=4a78b1580a434883af9fa973225e33a4‍
Reply
0 Kudos
KellyGerrow
Esri Frequent Contributor

Thanks for posting the links.

It looks like the pellet plant trails service that you have added to your web map, and then consume in the app is enabled for http only: http://gis.cityofflorence.com/arcgis/rest/services/PeletPlantTrailsWebMap/MapServer 

When you call the app using https, a secure connection can not be made with this service as this has not been enabled on the service, causing it to fail to load. In order to use https for your app, you will need to discuss the possibility of enabling ssl/https on the server hosting your service.

-Kelly

View solution in original post

WesMiller
Regular Contributor III

Thanks Kelly

Reply
0 Kudos