Enabling Attachments Toggle not showing on Hosted Feature Layers

1845
6
Jump to solution
04-06-2022 08:23 AM
USI_Consultants
New Contributor II

Hello, I am trying to create hosted feature layers for our organization to use in field maps to collect data. I have everything configured correctly except I cannot get the layers to allow photos when you bring them up in field maps. Everything on the online help says there should be an "Enable Attachments" toggle that will show up when I view the layer in my content of Arcgis Online. However, I do not see this option. Am I missing something? I'm assuming it's a setting I missed somewhere. 

Thanks!

Tags (1)
1 Solution

Accepted Solutions
Katie_Clark
MVP Regular Contributor

Hello! To enable attachments in AGOL for a feature layer, you do that from the item details page. First click the arrow next to the layer you want to enable attachments for:

Katherine_Clark_0-1649258901700.png

 

The on the right side of the page, you can toggle attachments.

Katherine_Clark_1-1649258950815.png

 

 

 

Best,
Katie


“The goal is not simply to ‘work hard, play hard.’ The goal is to make our work and our play indistinguishable.”
- Simon Sinek

View solution in original post

6 Replies
Katie_Clark
MVP Regular Contributor

Hello! To enable attachments in AGOL for a feature layer, you do that from the item details page. First click the arrow next to the layer you want to enable attachments for:

Katherine_Clark_0-1649258901700.png

 

The on the right side of the page, you can toggle attachments.

Katherine_Clark_1-1649258950815.png

 

 

 

Best,
Katie


“The goal is not simply to ‘work hard, play hard.’ The goal is to make our work and our play indistinguishable.”
- Simon Sinek
USI_Consultants
New Contributor II

THANK YOU! I knew it was something easy I was missing. I really appreciate it!

0 Kudos
CAustreng_TriCountHD
New Contributor

What do I do if the attachment toggle still does not show

 

LayerItOn
New Contributor III

Hi, I am still not seeing the attachment toggle or a setting to enable. Is there another way? 

0 Kudos
Katie_Clark
MVP Regular Contributor

@CAustreng_TriCountHD @LayerItOn 

Are you working in ArcGIS Online or Portal? Are your layers hosted feature layers?

Best,
Katie


“The goal is not simply to ‘work hard, play hard.’ The goal is to make our work and our play indistinguishable.”
- Simon Sinek
LayerItOn
New Contributor III

Hi @Katie_Clark and CAustreng_TriCountHD,

I ended up figuring it out thankfully!

First I had to click on the feature layer > item details > then under layers click the layer again (I don't totally understand this, aren't we already looking at the feature layer [not hosted feature layer]? And now I have to look at the layer again under layers?  😶 I suppose a feature layer can have more than one layer, but it's odd when there is only one layer) 

LayerItOn_1-1701971565205.png

Anyways, when I click on the layer > enable attachments on the bottom right 

LayerItOn_2-1701971678388.png