Customized Popup not supporting style?

96
2
Jump to solution
10-03-2019 04:02 AM
Highlighted
Esri Regular Contributor

I customized the popup for one of my layers to show only three attributes of which two display arcade expressions. Because I also want to hide the label if the result is empty I designed the popup with a table to reproduce the same design as the "normal" popups. I added a style so the attribute names are equally grey-ish as regularly. This works great in my web map until I close it -  when I open the map again or use the map in an web application the popup seems to remove the "style" element and puts my customized style as part of the popup text. 

Is that an expected behaviour? 

It seems to keep the styling when using css inline though...

Reply
0 Kudos
1 Solution

Accepted Solutions
Highlighted
Esri Regular Contributor

I thought I tried it before but now it works. Maybe also because I added the correct style to the table now as well. Before I only tried the td classes. 

View solution in original post

Reply
0 Kudos
2 Replies
Highlighted
Esri Esteemed Contributor

Hi Nicole Ueberschär ,

I have noticed in the past, that defining css in the custom html pop-up. I once ended up changing completely the TOC of the web map due to overwriting the css through the pop-up. 

It is strange that it shows the correct result but on refresh it rejects the css and converts it to plain text. I wonder, since the styles are already present in the web map, if you cannot use the styles and simply use them by name of id in the pop-up.

Reply
0 Kudos
Highlighted
Esri Regular Contributor

I thought I tried it before but now it works. Maybe also because I added the correct style to the table now as well. Before I only tried the td classes. 

View solution in original post

Reply
0 Kudos