Custom Symbology Not Working since December AGOL update?

243
9
Jump to solution
02-23-2022 01:48 PM
GIS_utahDEM
Occasional Contributor

Hi! I had shared a web style from ArcGIS Pro to ArcGIS Online last year, and had successfully symbolized off of it, but it is no longer showing up as a shape option/category. I'm wondering why this is, and if it's still possible to use my custom symbols (for new layers and maps)?

Thanks in advance. 

0 Kudos
1 Solution

Accepted Solutions
RussellRoberts1
Esri Frequent Contributor

Thanks! Its an issue with styler reading in the symbol layers. For a workaround you can add a shapemarker layer and set the color to no color in the symbol within the desktop style.

RussellRoberts1_0-1645719320319.png

 

When you publish it will work

RussellRoberts1_1-1645719382661.png

 

 

Or if you have SVGs for the symbols you can use those as a shapemarker within the webstyle and that will work as well.

 

View solution in original post

0 Kudos
9 Replies
RussellRoberts1
Esri Frequent Contributor

Is it no longer shared to the default group setup in your organization?

0 Kudos
GIS_utahDEM
Occasional Contributor

@RussellRoberts1 Yes, it is shared publicly and with my organization's default web styles group.

0 Kudos
RussellRoberts1
Esri Frequent Contributor

Can you share a link to the style? 

0 Kudos
GIS_utahDEM
Occasional Contributor
0 Kudos
RussellRoberts1
Esri Frequent Contributor

Thanks! Its an issue with styler reading in the symbol layers. For a workaround you can add a shapemarker layer and set the color to no color in the symbol within the desktop style.

RussellRoberts1_0-1645719320319.png

 

When you publish it will work

RussellRoberts1_1-1645719382661.png

 

 

Or if you have SVGs for the symbols you can use those as a shapemarker within the webstyle and that will work as well.

 

0 Kudos
GIS_utahDEM
Occasional Contributor

@RussellRoberts1  Thank you! I can now see it in the Map Viewer, but unfortunately I cannot see it in the symbology within the visualization tab of the layer. I need to set it there because I am creating 200+ view layers and I need them all to maintain the same complex symbology. Is it possible to have custom symbology applied in the visualization tab? 

0 Kudos
RussellRoberts1
Esri Frequent Contributor

The viz tab is still based on 3.x JSAPI like Map Viewer Classic and cannot display these complex symbols yet. Updating to 4.x is on our roadmap along with styler updates that wouldn't require this workaround.

0 Kudos
GIS_utahDEM
Occasional Contributor

Haha dang. Any eta on that? 

Thanks for all your help though!

0 Kudos
RussellRoberts1
Esri Frequent Contributor

Viz and Styler updates planned for a release later this year

0 Kudos