Arcade expression for Pop-Ups with display some expressions but not others

520
9
Jump to solution
01-13-2020 10:19 AM
BrianBerdel
New Contributor III

The Arcgis Arcade expressions I'm using for my popup only show the result of some of the fields and not others.

Project Type: {subtype}
{proj_title} - {proj_id}
Status: {STATUS}
Restriction Type - {restriction_type}                                  
Start Date: {starttime}
End Date: {endtime}   

-------------------------------------------------------------------------------------------------------------------------------------------

Result -->      

---------------------------------------------------------------------------------------------------------------------------------------------

I don't need any calculations I just need the result of the field to appear. All the fields I want in popup are filled in and not blank, the Field Names match what I put in the configuration, I made sure all features have a result that is in the dropdown menu if it has one. I'm not really sure what else to try.

Any help would be appreciated!

Thanks,

0 Kudos
1 Solution

Accepted Solutions
BrianBerdel
New Contributor III

I tired Firefox and Chrome. I ended up deleting the field and creating a new one and then it worked.

Thank you for your help!

View solution in original post

0 Kudos
9 Replies
XanderBakker
Esri Esteemed Contributor

Hi Brian Berdel ,

I suppose you are showing the configuration of the pop-up in the web map, right? Which fields are supposed to be Arcade expression? At first glance non of them appear to be Arcade expressions. Can you share the expression of an attribute that shows and one of an attribute that does not show?

0 Kudos
BrianBerdel
New Contributor III

Here are two expressions that shows correctly in the popup

1. return($FEATURE.ST_RT_NO)

   - {expression/expr7

2.return($feature.street)

   - {expression/expr8} 

In the Custom Attribute Display I put the below statement

   - State Route {expression/expr7} - {expression/expr8} 

   - And received the correct information -->

For the one that isn't working

1. return($Feature.RESTRICTION_TYPE)

     - Restriction Type - {expression/expr15}

     - And it's doesn't populate

0 Kudos
XanderBakker
Esri Esteemed Contributor

Hi bberdel 

Thanks for sharing the configuration of the pop-up, but can you also share the actual Arcade expressions?

0 Kudos
BrianBerdel
New Contributor III

I did, they're labeled 1., 2., 1. or is    return($feature.-----) not an expression?

0 Kudos
XanderBakker
Esri Esteemed Contributor

Hi bberdel ,

Indeed I see the expression:

return($Feature.RESTRICTION_TYPE)

However, this expression does not do anything with the attribute, so there is no need to use an Arcade expression. You can use the attribute directly...

BrianBerdel
New Contributor III

I tried using the attribute directly originally and it still wouldn't display the value even when the field was filled out. That's when I tried to use expressions and that didn't work either.

Is there a reason why the direct attribute wouldn't display even though the field is filled in?

0 Kudos
XanderBakker
Esri Esteemed Contributor

Hi bberdel , 

That is very hard to determine without access to the data. One should verify the requests using the developer interface in the browser (which browser are you using?) and the corresponding responses and if any errors are present. Is it possible to have access to the data? The fact that an value is not returned when it should could be a reason to contact support.

BrianBerdel
New Contributor III

I tired Firefox and Chrome. I ended up deleting the field and creating a new one and then it worked.

Thank you for your help!

0 Kudos
XanderBakker
Esri Esteemed Contributor

Hi Brian Berdel ,

Very strange behavior, but I'm glad you solved! 

0 Kudos