Hosted Feature Service Popup Does Not Match ArcGIS Pro Attribute Table

270
2
11-26-2018 11:55 AM
Status: Open
VeritaAdmin
Occasional Contributor III

My observations are as follows:

  • Hosted Feature Service Pop-Up Configuration is not reflected when the layer is viewed in ArcPro.
  • When field order of a Hosted Feature Service is adjusted in ArcGIS Pro (i.e. field added or re-ordered), the "Data" Table and the popup configurations are not reflected in ArcGIS Online.
  • When new fields are added in ArcPro (and made "visible"), the Hosted Feature Layer has these new fields not "Displayed" by default.

Is this expected functionality? Please see attached snip for more details.

Info appreciated!

2 Comments
KoryKramer

At this point this seems more like a question for the ArcGIS Online‌ rather than an idea.  Are you making any changes to the pop-up configuration when the hosted feature service is in Pro?  

I can say that the order of the fields you see in your attribute table in Pro may be different than the order of the fields in the database itself (or the order they're stored in the hosted feature service).  And neither of these necessarily has anything to do with what you see in the pop-up as it is possible to configure what displays in the pop-up entirely separately from what is stored in the database, and how the table is set up for the layer.

For example, go to Fields View in Pro and you can toggle between Data Source and the layer:

I can't change the order or visibility of fields that are in the data source.  They are there.

But on the layer, I can change visibility and order.  That is what would be seen in the attribute table.

I could then further refine the pop-up to show even fewer fields, in a different order, or no fields at all. 

As for what the expectation is, probably better a question in the ArcGIS Online‌ space.

VeritaAdmin

In AGO, configuring the popup (Visualization Tab of Hosted Feature Service Item Details) also impacts the field configuration as displayed in the Data Tab and in the attribute pop-ups in WebMaps/Apps.

I would expect these Hosted Feature Service popup/field configurations in AGO to be visible in ArcPro.


I just checked in ArcMap Desktop and the Hosted Feature Layer fields in the attribute table are not in the same order as configured in AGO. Additionally, it seems no matter what fields are checked to "Display", they all show up when viewed in ArcMap Desktop (similar to Pro).

I would think that ArcGIS Online, ArcPro, and ArcMap would be compatible with AGO-configured Hosted Feature Layers. Perhaps this is not the case. I know this functionality would improve our workflows and undoubtedly many others'.