Allow New Map Viewer to Actually Create Polygons

695
18
07-14-2021 01:33 PM
Status: Open
WardMitchell2
New Contributor II

Hello, I'm trying to draw a polygon in the new map viewer and it does not work. Editing is enable on the layer. I select edit then Add feature and I am unable to draw a polygon in the new map viewer. It works fine in the old map viewer. We are having to work between the map viewer classic and and the new map viewer to get the desired result. Are there any suggestions on how to create a simple poly gone in the new map viewer? Is this just ESRI just throwing out another half baked product? 

 

Tags (2)
18 Comments
RussellRoberts1

I am able to add polygons with my editable layer. Can you share the layer you are having an issue with and I can take a look?

RussellRoberts1

Also does your Polygon have Z values set to true?

WardMitchell2
Don’t know what that means.
RussellRoberts1

If you can share your layer I can check. If it does then its related to a bug with the editor widget in the JSAPI . If you want to you can track it with this ID BUG-000141323

WardMitchell2
I re-hosted the layer with disabled M and Z values and still have the same result. Below is the layer url.
https://services7.arcgis.com/2L9nlPlkmAzDWOHn/arcgis/rest/services/ParkingLots_Update/FeatureServer
RussellRoberts1

Looks like the layer isnt shared publicly. You can pop it into a group and invite russell_jsapi to it.

WardMitchell2
Yep it wasn’t but is now
RussellRoberts1

That layer does not support Editing(Add, Update, Delete).

 

 

WardMitchell2
It is now