Topoengine Error

416
14
03-07-2019 06:02 PM
Highlighted
New Contributor II

By using closest facility, I found closest path between 78 points. Now, I am trying to split this route at intersection points by using feature to line management tool. However, I am getting a Topoengine error. What I tried to solve this problem is that :

1. I used repair geometry.

2. I used check geometry.

3. I unchecked background processing from geoprocessing option.

4. I copied the data to new file geodatabase.

But, I could not fix this problem. If you have any suggestion to me, I will be appreciated for that. 

Thanks !

Reply
0 Kudos
14 Replies
Highlighted
Esri Regular Contributor

Have you tried changing (not specifying) the XY tolerance?

Are you able to do some other geometry operations on the output routes. That is, try exporting the routes to a line feature class or buffer them.

Jay Sandhu

Reply
0 Kudos
Highlighted
New Contributor II

I tried not specifying the XY tolerance, but again I had an error.

How can I export the routes as line feature class ? When I click on export the data, I could not see this option.

I used buffer tool, but I am still waiting to have a result.

Thank you so much !

Reply
0 Kudos
Highlighted
New Contributor II

Do you have any other suggestion to me ? I could not fix the problem.

Reply
0 Kudos
Highlighted
MVP Esteemed Contributor

Something to try: Run the Integrate tool (on a copy of the FC of course) to see if that will cleanup your futzy geometry.

Reply
0 Kudos
Highlighted
New Contributor II

I tried, I have an error  " Invalid topology  (out of memory). Failed to execute (Integrate)"

Reply
0 Kudos
Highlighted
Esri Regular Contributor

It looks like the original data has some corruption. Are you running the topology, intergrate, etc., on the original or the resulting route layer? You may want to contact Esri tech support and have them get the data in house and take a look at it.

Jay Sandhu

Highlighted
New Contributor II

 I am running resulting route layer. Maybe, I did something wrong at the beginning, that's why I have an error. This is what I did :

I create network analysis from North America Major Highway. After that, I used closest facility to find shorthest path between 78 points. However, I found just 90 routes (From analysis setting, I set up as 78). I have no idea why I had just 90 routes. 

Then I decided to apply feature to line tool to North America Major Highway, then I created network analysis, after that, I used closest facility and I found 78x78 routes. Then, I exported this shorthest path and I tried to use feature to line tool to this shorthest path, but I had a topoengine error.

Do you think that is this creating problem ?

Reply
0 Kudos
Highlighted
Esri Regular Contributor

What is the source of the original data for "North America Major Highway"? 

Reply
0 Kudos
Highlighted
New Contributor II

This is the data I used :

https://www.arcgis.com/home/item.html?id=e8a316cc5ab44da8962108ff8c59dc6c 

Thank you so much !!

Reply
0 Kudos