Problems with Insights for ArcGIS

3593
8
06-17-2017 04:59 PM
SalemAlghamdi
New Contributor

I have two problems with Insights for ArcGIS which are:

  • Error 1 (Workbook Card): “Something went wrong”.
  • Error 2 (New Connection Database): “Something went wrong with this database connection. Check to see if the connection properties need to be updated”

 How can I fix this issue?

However, I already installed SQL server and I uploaded Java Database Connectivity (JDBC) files on the portal's hosting server.

0 Kudos
8 Replies
EDN_SWORDSIG1
New Contributor

Same issue here

0 Kudos
by Anonymous User
Not applicable

Me too. Insights will not display any spatial data. I see the attributes and can even chart them, I just cannot see the.

I get the "Something went wrong" message, which is not helping.

0 Kudos
AravindStoryMaps
Esri Regular Contributor

Hi Salem,

Thank you for this post. Do you mind if you can expand a little on the ArcGIS Enterprise environment that you're using:

1. ArcGIS Enterprise 10.5 or 10.5.1?

2. Based on the answer to this above question, you'd need to have the appropriate Insights for ArcGIS version: ArcGIS Enterprise 10.5 supports upto Insights for ArcGIS 1.2.1; ArcGIS Enterprise 10.5.1 supports Insights for ArcGIS 2.0 onwards (Documentation reference: Compatibility with Portal for ArcGIS—Insights web help Use tab | ArcGIS Enterprise).

Error 1 could occur during specific workflows. Could you expand on what was the workflow done to cause the "Something went wrong" error?

Let's focus on Error 2:

1. The JBDC Driver needed to connect to SQL Server is sqljdbc42.jar. (SQL Server versions supported - 2012, 2014, 2016). 

2. Once you've followed the steps to register relational data store types, it's important to remember to restart the ArcGIS Server windows service on the Server machine.

3.  Additionally, Insights doesn't support database connections to your Enterprise geodatabase. (Supported databases—Insights web help Use tab | ArcGIS Enterprise ).

4. Also verify that the ports to SQL Server can communicate with ArcGIS Server & Portal for ArcGIS machine. 

I look forward to your response. 

Thanks,

Aravind

0 Kudos
by Anonymous User
Not applicable

I am working with Insights for ArcGIS 5.1. Is it possible my ArcGIS Enterprise is 10.5? How do I check this?

Thank you.

Randy McGregor

0 Kudos
AaronKreag4
New Contributor

Same issue here with the Insights on Portal and database connection.  10.5.1 enterprise and 2.x Insights.  Went through all of the documents for hours, checked everything and looks good.  Using the 6.0 jdbc on MS site.  Still wont connect to a database.  We have a single server deployment but its pretty locked down.  The database info for the connection should be how we would connect to the database like in ArcCatalog while on network or does the database have to have external exposure and external credentials?  Cant find actual login examples for different deployments. Can you give more info on the login page?  The port field isn't required but in the online document it says it will not work without the port number.  Thanks!

0 Kudos
by Anonymous User
Not applicable

Our admin guy told me that the problem was with the version of Oracle that is supporting the gis data. He suggested I used a hosted feature service, and that did the trick. I can see the features.

0 Kudos
AaronKreag4
New Contributor

I have no issue with GIS data and Insights. The only thing I am having an issue with is the Connect to a data source – DATABASE – Create a New Connection

Get an error, cant find the regular (non spatial) database.

0 Kudos
MuhammadWaqar_ul_islam
New Contributor III

I have installed Arcgis Enterprise 10.6 server portal data store and insight 2.2.1 version on single server machine.

Unable to load feature layer something went wrong appers. Tried every thing but unsuccessful to run.

Feature layer  is working fine in portal but not added in insight

Please help in this regards

0 Kudos