cant create new insights workbook

4162
10
04-04-2017 04:53 PM
joshjones
New Contributor II

I recently installed portal and have installed and authorized Insights.  I am able to access the application but on the my workbooks page I have no workbooks listed and when I hit the Start new workbook button nothing happens. any help?

10 Replies
AravindStoryMaps
Esri Regular Contributor

Insights for ArcGIS requires a Base Enterprise 10.5 deployment: 

  • Portal for ArcGIS 10.5,
  • ArcGIS Server 10.5 (GIS Server license) - federated with Portal and designate this server as a hosting server by installing
  • ArcGIS Data Store 10.5 - register with the above Server.
  • Two web adaptors - Server and Portal (IIS/Java).

If you have this and still see the problem, please go to My Content and choose "Create". You should see the following option in the dropdown "Feature Layer". If you're missing this, then there's probably some issue with creating hosted feature services in Portal/Server. 

Thanks,

Aravind

0 Kudos
AndreaGironi
New Contributor

I have the same problem, the cause is a certificate violation that fires when you click on the button, for some reason it's trying to call the phisical machine instead of the public domain

0 Kudos
DouglasCochran
Occasional Contributor II

This seem to be ArcGIS Enterprise configuration issues.  Did you get this resolved?  If not, I suggest you open a ticket with Esri customer support to get you up and running right away.

Regards,

Doug

0 Kudos
AndreaGironi
New Contributor

I can tell you what was the problem here

If you federate portal and server using the private url (aka the one with phisical machine fully qualified name and ports 6442, 7442) as suggested on the install guide, the data store will NOT work when accessing the portal from the web adaptor url from a machine that cannot access the private url, the same will happen if you publish the portal/server through a proxy.

The only way to make this work for us, was to federate portal and server using the proxy url and port

Regards

0 Kudos
DouglasCochran
Occasional Contributor II

Thanks for more detailed info.  I will pass this info along to the ArcGIS Enterprise team.  

Regards

0 Kudos
ChrisBlinn1
Occasional Contributor

I too am having this issue.

I removed the federated server, and federated again following the suggestion to use the administrative path for both URLs.

That resolved the issue I saw on this post about not seeing Feature Layer as options in the Add Items drop down menu.

My error changed in Insights to "Error: Create Service error: Servlet execution threw an exception".

Any ideas?

0 Kudos
AravindStoryMaps
Esri Regular Contributor

Hey Chris,

Is Insights installed on both Portal & Server, if they are on separate machines? If it is, can you find out if you can publish a feature layer from Create Feature Layer option in My Content in Portal?

When you create a new workbook in Insights, it creates a hosted workspace service in the ArcGIS Data Store of the hosting server that you just refederated. So, if you're having workbook issues, I'd recommend making sure you can do this task first to ensure the Enterprise is up and functional. 

Thanks,

Aravind

0 Kudos
ChrisBlinn1
Occasional Contributor

Thanks - it turns out it was a couple things.

First, I had issues not being able to create/add content so I changed the unfederated, and then federated again using the admin path for both URLs.  That appeared to fix the first issue.  Second, I had troubles with creating the workbook and was receiving two different errors; certificate error, and servlet error.

I had a chat with Esri yesterday and we got most of everything squared away, however now I am seeing old items in my insights Add Data page.  Here is what we did:

  1. Installed Insights on ArcGIS Server box
    • This allowed me to create a workbook, but not add data
    • The URL for the data was incorrect (using https and port 6080)
  2. Tried updating the federated server paths on the Sharing Rest page
    • This worked for changing the paths to the portal and admin paths, but we kept seeing Internal Server 500 Errors
  3. Unfederated server
  4. Federated server using portal URL and admin URL
    • This allowed me to add data with the correct URL, but we had old data showing up in Portal
    • We deleted the items from the arcgisportal folder, which removed them from Portal, but not from the Insights Add Data page
  5. Uninstalled Insights on Portal machine
  6. Repaired install of Portal
  7. Installed Insights on Portal machine
  8. Uninstalled Insights on ArcGIS Server machine
  9. Installed Insights on ArcGIS Server machine
    • Everything is working normally, except on the Add Data page of Insights you still see the old items.
    • They do not appear in Portal.
0 Kudos
HarroldSompotan
Esri Contributor

Just wanted to add a NOTE here on this post:

If you are running ArcGIS Enterprise in a distributed environment, Insights must be installed on every machine running Portal, and the hosting GIS Server.  As noted here: http://server.arcgis.com/en/insights/latest/administer/windows/install-insights-windows.htm 

"The setup program detects whether Portal for ArcGIS or ArcGIS Server is installed on your machine, and installs the appropriate Insights feature. On a single-machine deployment, you only need to run the setup once. If your Portal for ArcGISis configured in high availability, you need to run the setup program in both portal machines. If your hosting server is a multi-machine site, you need to run the setup program on all of the machines in the hosting server site"

Hope this helps.