Open Data download issues

3997
13
07-06-2015 12:05 PM
JimCourson
New Contributor

I'm having trouble downloading polygon data from Open Data since the latest updates were applied. Three datasets that previously worked now fail to download. In some cases the data gathering completes, then I get "The spreadsheet you requested is currently unavailable". In other cases the data gathering fails with the following message "spreadsheet – An error occurred while processing this dataset". Point data still downloads fine, but polygon data fails. The services work fine outside of Open Data. Any ideas?

Tags (1)
0 Kudos
13 Replies
DanielFenton1
Regular Contributor

Hi Jim,

Can you please post the datasets you are having issues with?

Thanks,

Daniel Fenton

Product Engineer | Open Data

0 Kudos
ChristopherBoland
Occasional Contributor
0 Kudos
DanielFenton1
Regular Contributor

Have you tried hitting the reset button in your admin data repor?

0 Kudos
ChristopherBoland
Occasional Contributor

I hadn't before now, but because the data were not reporting any Errors or Warnings, I didn't think I had to.  It is a little unclear to me what that button is actually supposed to do.

0 Kudos
DanielFenton1
Regular Contributor

That’s good feedback.

The button will both drop the download cache and reharvest the dataset. It’s the equivalent of jiggling the handle…as in, it usually works.

0 Kudos
DanielFenton1
Regular Contributor

To clarify a bit more:

Sometimes services will fail when requesting data to buid the downloads. This can cause the download process to have issues and never finish generating the cached file. Dropping the download cache via the ‘Resync button’ restarts this process.

We are adding more processing checks to hopefully prevent these intermittent issues from occurring, you’ll see those start to show up very soon. We are also working on alerting you when there are download errors.

0 Kudos
DanielFenton1
Regular Contributor

Hey Chris,

The fish management dataset seems to be working fine. Are you still having issues?


Also, this dataset no longer exists: http://geodata.myfwc.com/datasets/a78160f5acaf4439b49f9fbef4c100ac_5

My initial analysis is that the complexity of the features in seagrasses and salt marches are giving us the trouble. I'm continuing to debug locally so we can figure out a solution.

0 Kudos
DanielFenton1
Regular Contributor

We've zeroed in a fix for at least: http://geodata.myfwc.com/datasets/4d1b4e758e704def90773bd49806dd4c_6  and should be testing it soon. I'll keep you posted.

0 Kudos
DanielFenton1
Regular Contributor

Hey Chris, it looks like this server is failing to execute queries at all now. Did you make any changes to your service?

http://atoll.floridamarine.org/arcgis/rest/services/FWC_GIS/OpenData_MarineEco/MapServer/6/query?whe...

{

  • error: {
    • code: -2147209212,
    • message: "Failed to execute query.",
    • details: [ ]
    }

}

0 Kudos