New search route not finding document

350
5
08-22-2018 08:15 AM
KevinHibma-EsriCA
Esri Contributor

Hi, 

Per this: Enabling New Beta Search in ArcGIS Hub  - I've enabled the new search route on my Open Data site.

When looking at the datasets in the admin, I see 40 datasets, 39 spatial.

However, this dataset cant be found in my site -- doing a search for everything only returns 39.

Should I be able to find an Excel document? ( item in question: http://www.arcgis.com/home/item.html?id=5558b18217da4245bbc0c3e91999552a  ) 

It has been shared publicly and to the OD group for my site.

Tags (2)
0 Kudos
5 Replies
PatrickHammons1
Esri Contributor

Glad to hear you're using the new search route! Can you provide a link to your site? It looks like it's showing up in our index so I'll need a bit more information to triage your site.

KevinHibma-EsriCA
Esri Contributor

I was able to touch base with Patrick and he helped me better understand what the new search route does.

Enabling the Search route in the admin changes the route in the application when doing a search. Simply put, when you have a search widget and use it, you end up on a /datasets page. After switching to the new search, the default behavior in your app changes to /search -- an entirely different page view.

For my question specifically, the Excel document does show up under the /search endpoint (where it should). However my spatial datasets were not. This may or may not be an issue and Patrick and his team will investigate this. I've turned off the search route and will keep using the default search.

Thanks for your help, Patrick Hammons

0 Kudos
PatrickHammons1
Esri Contributor

Just a heads up that the discrepancy between /datasets and /search looks to be resolved. Feel free to try it out and let us know if you see any more issues!

KevinHibma-EsriCA
Esri Contributor

Hey Patrick,

I re-enabled Search and it looks good. I like it.

New question - the particular dataset I referenced above, when I browse data in the site, or do a search and find it. The title of the item is the name of the xlsx spreadsheet itself. In this case:  Opscriminalcodeoffences20112015.xlsx 

Is this intended? if so, I'll need to go back and fix some of the file names before uploading.

0 Kudos
PatrickHammons1
Esri Contributor

Thanks for the head's up! Looks like all documents were exhibiting the same bug, which we have resolved. Might take a day or so to filter through completely, but feel free to check again.

0 Kudos