Custom Domains

2430
9
Jump to solution
05-30-2017 03:04 AM
ONSGeography
New Contributor III

We had a custom domain called geopotal.statistics.gov.uk for our V1.10 website (http://opengeography-ons.opendata.arcgis.com) and we wanted to move that custom domain to our new V2 site (http://geoportal-ons.opendata.arcgis.com/ ). To do this we had to change the CNAME with our domain registrars. 

So we did the following 

"The DNS change we need to make to the geo portal is as follows:

currently: http://geoportal.statistics.gov.uk/ in CNAME http://opengeography.ons.opendata.arcgis.com/

but we want: http://geoportal.statistics.gov.uk/ in CNAME http://geoportal-ons.opendata.arcgis.com/"

Is that the correct procedure?

Thanks

Matt

0 Kudos
1 Solution

Accepted Solutions
CourtneyClaessens
Occasional Contributor III

Hi Matt, 

The CNAME should point to opendata.arcgis.com. Documentation: Configure your Open Data site—ArcGIS Open Data | ArcGIS 

To change the custom domain you just need to swap them in the site configuration. You shouldn't have to do anything else. 

Courtney 

View solution in original post

0 Kudos
9 Replies
CourtneyClaessens
Occasional Contributor III

Hi Matt, 

The CNAME should point to opendata.arcgis.com. Documentation: Configure your Open Data site—ArcGIS Open Data | ArcGIS 

To change the custom domain you just need to swap them in the site configuration. You shouldn't have to do anything else. 

Courtney 

0 Kudos
ONSGeography
New Contributor III

Hi Courtney,

So the CNAME should point to just opendata.arcgis.com rather than my whole site URL geoportal-ons.opendata.arcgis.com? 

At the moment the CNAME in the DNS settings is pointing to geoportal-ons.opendata.arcgis.com.

If I wanted the URL http://geoportal.statistics.gov.uk for my site http://geoportal-ons.opendata.arcgis.com I set the CNAME just to opendata.arcgis.com?

Sorry if that is really basic, I don't know exactly what I'm doing

Thanks

Matt

0 Kudos
CourtneyClaessens
Occasional Contributor III

No worries! You are correct: the CNAME should point to just opendata.arcgis.com rather than your whole site URL geoportal-ons.opendata.arcgis.com.

Once that has been switched the URL http://geoportal.statistics.gov.uk should work as expected. 

Courtney

ONSGeography
New Contributor III

Thanks Courtney! I'll let you know how I get on. I'll have to do it tomorrow as on UK time 

Thanks

Matt

0 Kudos
ONSGeography
New Contributor III

Also I get the following error when I try to update my custom domain to geoportal.statistics.gov.uk in my site geoportal-ons.opendata.arcgis.com

It says the domain is already registered to a site. Is it possible for you or Esri Inc to unregister this domain so I can add it?

Thanks

Matt

 

0 Kudos
CourtneyClaessens
Occasional Contributor III

We've cleared it and you should be good to go! 

Courtney 

ONSGeography
New Contributor III

Thanks Courtney, and you would recommend I change the CNAME before I update the custom URL?

Thanks

Matt

0 Kudos
ONSGeography
New Contributor III

Hi Courtney,

The CNAME change has been carried out to opendata.arcgis.com as shown below…..

 

I have made this change for you.

 

It looks as though whomever is in charge of the “arcgis.com” domain, has CNAMED “opendata.arcgis.com” to “prod-lb-2146348344.us-east-1.elb.amazonaws.com”.

 

Below is the output confirming the change is in effect:

 

C:\Windows\System32>ping geoportal.statistics.gov.uk

 

Pinging prod-lb-2146348344.us-east-1.elb.amazonaws.com [52.205.61.98] with 32 bytes of data:

Request timed out.

Request timed out.

Request timed out.

Request timed out.

 

Ping statistics for 52.205.61.98:

    Packets: Sent = 4, Received = 0, Lost = 4 (100% loss),

 

C:\Windows\System32>ping opendata.arcgis.com

 

Pinging prod-lb-2146348344.us-east-1.elb.amazonaws.com [52.73.19.216] with 32 bytes of data:

Request timed out.

Request timed out.

Request timed out.

Request timed out.

 

Ping statistics for 52.73.19.216:

    Packets: Sent = 4, Received = 0, Lost = 4 (100% loss),

 

C:\Windows\System32>

 

So I have added the custom URL geoportal.statistics.gov.uk into the site configuration, like so…

It worked fine it didn't say the site was already registered. I pressed Okay

 

However, when I press the save button on the site configuration page I get a different error as shown in the screen shot

So I don't know if the custom domain has saved or not?

 

On checking the URL geoportal.statistics.gov.uk it still takes me to http://opendata.arcgis.com/about

 

I have tried saving the site configuration on a different PC but I can replicate the error above.

 

Matt

0 Kudos
MiguelParedes
Esri Contributor

Greetings ONS Geography‌,

Did you ever resolve the issue you had with the CNAME?   I imagine so since your Open Data site openmappingdata.lambeth.gov.uk does now work.  

Would you please let me know what was the final value set for the CNAME?  Was it opendata.arcgis.com, or was it hub.arcgis.com?

Many thanks in advance.

Miguel

0 Kudos