Not able to subscribe to stream service

994
2
08-06-2018 12:46 PM
Highlighted
New Contributor II

I've published a stream service in GeoEvent 10.6 using the default data store / ArcGIS Server running on the same machine. The service is created as expected, but I'm not able to subscribe to it. I've tried to subscribe through a web map in ArcGIS Online, but also using the rest endpoint (http://<servername>/arcgis/rest/services/<service name>/StreamServer/subscribe). The error message I get using the dev tool of Chrome is

"Error during WebSocket handshake: Unexpected response code: 500.

I've recently federated the server to portal and I suspect that might be the problem as it used to work when the server was operating independently. However, I'm not able to find out why. 

Anyone?

Thanks, 

Inge

Reply
0 Kudos
2 Replies
Highlighted
New Contributor II

Hi Inge,

1) Do you get a message saying you have unsubscribed when you try to subscribe at Rest?

2) Is your GeoEvent Sever Federated? If yes, is the default datastore set to server or portal? If set to server please do the following;

1) Export your GeoEvent Server configuration to an XML;
2) Reset your GeoEvent Server configuration(https://community.esri.com/community/gis/enterprise-gis/geoevent/blog/2018/01/09/howto-administrativ...)
3) Enter credentials to your 'Default' registered server connection so that it will validate (connection type should be 'Portal' after configuration reset);
4) Import your configured inputs / outputs from the XML.

5) Subscribe to Stream Service.

~Leanndra

Reply
0 Kudos
Highlighted
Occasional Contributor

Leanndra

I tried the same thing (reset configurations as per 10.6.0) , I saw default connection type as Portal. But after a while, it got automatically changed to SERVER ; only thing I did was, imported some definitions from my another GeoEvent server, not sure this puts back default connection to SERVER type.

My Geoevent server is federated with Portal. I wish to use stream service as output from my azure event hub input. 

Need your advise.

Lakshmanan

Reply
0 Kudos