Open Field Maps from a link without opening a browser

1110
9
03-25-2021 09:05 AM
GarethBaker1
Occasional Contributor II

I'm trying to open the Field Maps app on iOS from a link that I've emailed to myself following the guidelines here:

Deploy your map—ArcGIS Field Maps | Documentation

As far as I can tell I'm using the correct syntax but whenever I click on a link it opens up the Edge browser on my phone and goes to a page where it prompts me to download Field Maps from either the Apple or Google Play store. 

The app is already installed on the device via Microsoft Intune so how do I force it to open that instance of the app rather than open the web browser?

9 Replies
DougMorgenthaler
Esri Regular Contributor

@GarethBaker1 you should be getting the web browser if it doesn't detect that the app is installed.  Can you provide some further detail on the specific link and parameters that you're attempting to use?

0 Kudos
GarethBaker1
Occasional Contributor II

Hi Doug,

I've tried a few different variations including:

https://fieldmaps.arcgis.app/?referenceContext=search&itemID= b47a269835f54388b8efffcd96e3112a&searc...

https://fieldmaps.arcgis.app/?referenceContext=open&itemID=b47a269835f54388b8efffcd96e3112a

And then for luck I also tried it with the portalURL setting (ArcGIS Enterprise 10.8.1). Just double checked the webmap ID is correct too.

iOS version is 14.4.1 and Field Maps is 20.2.1 build 264

Just checked on another iOS device with the same build/settings and I have the same issue of Edge opening up.

I noticed that some of the examples in the documentation have a slash before the question mark and some don't. However that doesn't seem to make a difference to the behaviour.

I'll maybe have a go at removing the app and installing with/without Intune to see if that makes a difference.

0 Kudos
ColinLawrence
Esri Regular Contributor

Those links look right. I am not super familiar with InTune but perhaps it is not working because Field Maps is installed on a different Profile than the email app? ie email is locally installed and Field Maps is on a managed profile. Are you able to install Field Maps outside of InTune as a proof of concept? What about setting a different default browser (in case Edge is the problem)?

 

Regards,

Colin

0 Kudos
GarethBaker1
Occasional Contributor II

Hi Colin,

Did a bit of testing with this by uninstalling Field Maps and installing directly from Apple store (I knew it was outside of Intune because our Intune config has the portalURL parameter set and that wasn't being applied in this case). Unfortunately it didn't seem to make a difference, just kept opening up Edge.

The browser settings on the device are slightly strange - the default browser was actually set to Safari but that seems to be ignored and Edge just opens up. Tried changing it to Chrome but again Edge kicks in - I will ask someone in our IT team if there is some sort of Intune policy that overrides the default browser and forces it to open Edge.  If so then that could be having an effect on behaviour of Field Maps links.

0 Kudos
GarethBaker1
Occasional Contributor II

Just to say there are also settings in the Outlook app on iOS to control which browser to open links with. This is also set to Safari but again is being ignored and links are opening up in Edge.

0 Kudos
ColinLawrence
Esri Regular Contributor

I installed Edge on my iPhone and set it as the default Browser and links are still working for me that I am tapping through the mail app. It could still have to do with an MDM configuration with the default Browser or something else in the MDM config.  Let me know what you find talking to your IT.

 

Regards,

Colin

0 Kudos
HannesVogel
New Contributor

I've got the same problem - the link inside Survey123 or as a QR code is working and Fieldmaps is opening on iOS, but not from any Enterprise secured app from Microsoft like Outlook, Todo, Teams ...

0 Kudos
ColinLawrence
Esri Regular Contributor

This can happen if you manually go to the link in the browser prior to installing Field Maps app. Here are a few workflows that have been used to successfully to clear out Safari as the preferred option to open app links:

1. Uninstall and reinstall Field Maps

2. Go to https://fieldmaps.arcgis.app in Safari, swipe the page down for the Smart Banner to appear, just under the URL banner. Tap the blue OPEN button in the Smart Banner seen in the image below. This should give preference to Field Maps over Safari next time link is opened.

3. Press and hold on the app link from an email, text message, etc. This will present the option on how you’d like to open the link. If you chose the option “Open in Field Maps” it should remember this for the next time.

 

I hope these help!

 

Regards,

Colin

0 Kudos
HannesVogel
New Contributor

Thanks for the answer Colin, I can follow your steps until step 2. But still the link is opening in edge with my company profile since this is my secured browser set up by the intune configuration. Safari is not even tried.

0 Kudos