Map Area data not refreshing and getting support

558
3
01-28-2021 10:35 AM
HeatherWidlund
Occasional Contributor

1) I don't seem to be able to pick ArcGIS Field Maps as a product on the Esri Support page. How do I start a support case online?

2) I set up a hosted feature layer and view which are sync enabled. I found some API for Python code to empty the feature layer using delete_features and append, since truncate doesn't work on sync enabled layers AFAIK. (The data are for viewing, not editing.) I also have it set to refresh the map areas through the Map Area interface daily, and have done it manually, too. Everything looks good on a feature with changed attributes, including searches in the Map Area interface, on the hosted feature layer and view in Map Viewer, and bringing the layers into Pro. However, ArcGIS Field Maps (on two different iOS devices) refuses to show updates. Even if I remove the area and re-download, the stale data remain. And on ArcGIS Online, the edit date for the layer is showing the original upload date, even though my script runs daily to delete/append. It's like AGOL is not registering the changes made through the API for Python and passing on that bad info to FieldMaps. Any suggestions? 

3 Replies
ColinLawrence
Esri Regular Contributor

Hello,

 

There should be an option to route a case under Field Maps, but if not you can select Online and mention in the notes you are using Field Maps; it should be routed to the correct person. The other option is to call in to create a case. 

 

I am curious, do you see the same issue with other map's map areas? Have you tried on Collector?

 

Regards,

Colin

0 Kudos
HeatherWidlund
Occasional Contributor

Thanks for the response, @ColinLawrence. When I follow the pull-down menus on support, under Apps and Mobile Apps, there is no option for Field Maps. I will try to call or choose Online.

It happens on other map areas, too. When I went back to my device just now after a day, it showed an update available for the map area I've been working with, which I downloaded. But the data are still stale. The map doesn't show up in Collector as an option.

0 Kudos
ColinLawrence
Esri Regular Contributor

Please follow up with me if you do not hear from someone. It does sound like it may not be a Field Maps issue as you noted you are seeing issues with the layer item in ArcGIS Online as well.

 

Regards,

Colin

0 Kudos