Error for geopsatial tools interpolation

427
10
02-26-2018 07:49 AM
HelgaGomes
New Contributor II

Hi,

I have a network of sampling points in the East China Sea. I would like to use the Interpolation tool in Spatial Analyst Tools -

I added a base map GSHHS_i_L1 and then my data from an excel spread sheet .xlsx and got the sampling locations. Then i brought in my spatial Analyst Took Bos, selected Interpolation -> Kriging

But I keep getting the error that i have attached in my docx file. Oddly my colleague did the same and hers works fine. I used her file to try and see if it worked and it did not. I am really at loss here.

Thanks

Helga

0 Kudos
10 Replies
SteveLynch
Esri Regular Contributor

Please use CopyFeatures to copy your data to a feature class and if the error persists when using the feature class then set the Processing extent to it in the Environment Settings.

0 Kudos
HelgaGomes
New Contributor II

Hi Steve,

Thanks for your reply. I am a bit of a novice so I am not sure exactly what I am supposed to do. I have my layers in the Table of Contents. I did hunt around online and got the Advance Editing Toolbar but that's greyed out. So really I am not sure how to follow your instructions. Sorry for the bother.

H

0 Kudos
SteveLynch
Esri Regular Contributor

Helga

No problem, we'll do it step for step.

The data from the spreadsheet, how did you get into into ArcMap? and please send a screenshot of the spreadsheet so that we can see some of the rows and what the columns are named.

-Steve

0 Kudos
HelgaGomes
New Contributor II

Thanks a lot Steve! I first used Add Data to get a base map in this case GSHHS_i_L1. Then I use Add Data to add my data from the Excel Spreadsheet, the snapshot of which I have attached. Then I right Click the layer and select Display X and Y to get my sampling locations. BTW I  have made sure that the header of my Excel spreadsheet did not have any spaces or special characters.  Then I went to the Tool box and Selected Spatial Analyst Tool --> Interpolation --> Krigging. Then I invariably get the error I posted above. That's it. Any help would be much appreciated! Helga

0 Kudos
SteveLynch
Esri Regular Contributor

Helga

Good.

Before you do kriging please goto to the DataManagement toolbox->Features and use CopyFeatures and copy this XY data you've just added to a feature class. Then use this feature class in kriging.

0 Kudos
HelgaGomes
New Contributor II

Hi Steve, I followed your instructions and i finally double clicked Copy Features and when the Copy Feature Menu came up i provided the Input Layer but I didnt change the Output Layer. I kept it at default. but again I got an error only i cant seem to retrieve it. In my earlier attempt i also got another message which I am posting.

Thanks a lot.

Helga

0 Kudos
HelgaGomes
New Contributor II

0 Kudos
HelgaGomes
New Contributor II

0 Kudos
SteveLynch
Esri Regular Contributor

Helga

I’d suggest that you contact ESRI Support.

Regards

Steve

0 Kudos